1

I have installed postfix, dovecot and squirrelmail. I can send messages and also receive messages. But in Squirrelmail web interface i can see only sent messages it is not showing the mails which are in inbox . Infact when I click on Inbox it showing THIS FOLDER IS EMPTY error.

But, I can see the received mails on the machine . Below are the mails which i have received from gmail,outlook.

 [root@a new]# pwd
 /home/bobby219/Maildir/new

 [root@a new]# ls -lrt
total 48
-rwxrwxrwx 1 bobby219 bobby219  5082 Mar 18 16:37 1426711022.Vfc00I20631M450759.a
-rwxrwxrwx 1 bobby219 bobby219  8763 Mar 18 16:42 1426711375.Vfc00I20635M700199.a
-rwxrwxrwx 1 bobby219 bobby219  9987 Mar 18 17:08 1426712892.Vfc00I20639M341101.a
-rwxrwxrwx 1 bobby219 bobby219 11207 Mar 18 17:09 1426712994.Vfc00I2063bM146743.a
-rwxrwxrwx 1 bobby219 bobby219  2664 Mar 18 17:10 1426713056.Vfc00I2063dM909489.a
[root@a new]#

POSTFIX

[root@a new]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, $mydomain
mydomain = example.com
myhostname = example.com
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
unknown_local_recipient_reject_code = 550
[root@a new]#

DOVECOT

[root@a dovecot]# cat dovecot.conf
# 2.0.9: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-431.1.2.0.1.el6.x86_64 x86_64 CentOS release 6.5 (Final)
mbox_write_locks = fcntl
passdb {
  driver = pam
}
passdb {
  driver = pam
}
protocols = imap pop3
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
ssl_cert = </etc/pki/dovecot/certs/dovecot.pem
ssl_key = </etc/pki/dovecot/private/dovecot.pem
userdb {
  driver = passwd
}
userdb {
  driver = passwd
}

mail_location = mbox:~/mail:INBOX=/var/mail/%u
[root@a dovecot]#
  • My suspicion is that SquirrelMail is looking in the wrong directory for messages. Double-check your paths there and make sure that they're correct. – Katherine Villyard Mar 18 '15 at 21:33
5

I'm not an expert in either dovecot or postfix, but it looks like you have postfix configured to use Maildir style mailboxes, but you're telling dovecot to use mbox style mailboxes.

Take a look at the postfix docs for the home_mailbox config option, or the dovecot docs for the mail_location config option to figure out which one you need to change (and what to change it to).

  • Thanks alot... Problem solved after changing the mail_location = maildir:/home/bobby219/Maildir in dovecot file. Now I'm able to see the Inbox as well as sent items. – Prime Mar 18 '15 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.