I needed to do some work on a KVM guest. To be able to go back to it's previous state, I took a snapshot:

virsh snapshot-create vph-share

After this, I tried to SSH into the VM:

ssh vph-share.hexvm

But I got

ssh: connect to host vph-share.hexvm port 22: No route to host

This worked fine before I took the snapshot.

I took a look at the snapshot-list, it looked normal. I then tried to log in again, and got

ssh: connect to host vph-share.hexvm port 22: Connection timed out

I also tried a virsh shutdown, but although virsh reports that the VM is being shutdown in reality it isn't. A following virsh start says that the VM is already active.

I tried virsh reboot and got:

error: Failed to reboot domain vph-share
error: Requested operation is not valid: Reboot is not supported without the JSON monitor

I tried the same actions on another VM on my server, without problems.

The log (/var/log/libvirt/qemu/vph-share.log) only has a note about the shutdown attempt:

2015-03-19 09:14:43.445+0000: shutting down

How can I get this VM back to work again?

The OS of the host machine is Ubuntu Server 12.04.
The OS of the KVM guest is Ubuntu 12.04.


I noticed that, unlike the other VM's, this VM's image was owned by root:root.

I tried to chown it to libvirt-qemu:kvm like the other VM's, but the ownership changed back to root:root automatically.

However, this did cause the VM to be in "shut off" state. Starting it with sudo virsh start vph-share brought it back to life.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.