1

I regularly use remote desktop to connect to PC's at work instead of going an physically sitting on the machine. We have 2 new computers, 1. Windows 7 2. Windows 8.1 ... I'm trying to connect to them view their internal IP address and it's not having any of it.

On the computers in question I have:

  1. Enabled Remote Desktop in Computer Properties.
  2. Allowed the port through the Firewall.
  3. Allowed Remote Desktop through the firewall.
  4. Fixed the IP address so it doesn't change.
  5. Stopped the computer sleeping.
  6. Enabled Network sharing and visibility options.

I'm running out of ideas and I need to get this up and running before we apply the external ip addresses.

As I mentioned I can remote to other PC's in the office, so it shouldn't be anything wrong with the network.

7
  • 5
    If you try and ping the computers, do you get a response? When you say enabled, did you also give permissions to your user to rdp in? What is the actual error message that you're getting (besides the machine wanting none of your rdping) – Reaces Mar 19 '15 at 10:22
  • 2
    how about defining "It's not having any of it"? I'm not aware of that being a recognised error message anywhere in Windows in general, let alone the client or server side of the RDP stack in particular. – Rob Moir Mar 19 '15 at 10:45
  • 2
    and it's not having any of it What does this mean??? What error-message are you getting. Does the machine you're trying to control have a password for the account you're using to get in? – Rik Mar 19 '15 at 10:45
  • 1
    What checkbox did you tick when enabling RDP? Allow... with any version or RDP or the more secure Only allow with NLA? What version of Windows do you have on your own PC? – Rik Mar 19 '15 at 13:23
  • 1
    @Rik I have tried connecting from Windows 7 & 8, the options that have been ticket are that available; Allow remote connections to this computer this is the only tick box available on the machine, it's running Windows 7 Home Premium. I do have additional options on my computer which is running Windows 7 Proffesional, for example the option you mentioned. But that tick box option isn't available on the computer I'm attempting to connect with. – Shaun S Mar 19 '15 at 13:42
2

You have a Windows 7 Home Premium. That version doesn't allow access via Remote Desktop. The ticked option you mention is for "Remote Assistance". You need to "invite" the remote party to view your computer with "Remote Assistance". You can see this from the checkbox is in the "Remote Assitance" groupbox and not in the "Remote Desktop" groupbox.

If you want to use RDP onto this machine you'll need to upgrade to Professional or use another form of remote control.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.