0

Okay the situation is this.

Yesterday my company changed our dns server, because our former one, was too unstable to work with. anyway today i went to one of our mac server, because it needed to be configured because of the new dns server. So i tried logging in to the local admin, because it couldn't find the network account server, because of the domain shift, but it just froze when trying to log in.

Okay so I went down to our server room to get a look at it locally. I tried logging in to the local admin, but i froze again. So i tried pulled the network cable out, and suddenly i could login just fine.

I tried logging in via vnc once again and it just hanged. better than it freezing, but still a problem. so i logged in locally. went to system preferences to edit the path to the network account server, so the mac server could find it once more, but then it just froze the system preferences when i went to login options.

So i restarted back and forth some time and finally got to edit the path to the network account server, but when i typed it in, the mac server just say that the network account server is not responding although all other computers, both linux and mac, are using it just fine. I tried updating, rebooting without the network. tried FQDN for the network account server, it's ip, it's hostname nothing work.

Does anyone have any clue to what is going on? cause I really have no idea what to do, other than maybe reinstall the system, which i would like to avoid if possible.

  • Did you update the DNS settings to point to the new server? – Sven Mar 19 '15 at 12:06
  • yes the dns is set to point to the new server – Tomas Mar 19 '15 at 12:13
  • better? and sorry for spelling errors. The question was rushed a bit – Tomas Mar 19 '15 at 12:21
  • @Reaces yes, thank you. I will keep that in mind :) – Tomas Mar 19 '15 at 12:38
  • @tomas You say that you unplugged the network cable, logged in, then changed the settings. However did you plug your network cable back in? What happens if you try and ping to the new / old dns servers? – Reaces Mar 19 '15 at 12:38
0

Short answer: make sure the new DNS server has (or can quickly resolve) both forward (name -> IP) and reverse (IP -> name) entries for the Mac server.

Long answer: OS X Server tends to like to look itself up via DNS, even for things you wouldn't expect DNS to be involved in at all. (I think it's a side effect of checking its own hostname via a reverse lookup of its primary IP address.) If the lookup succeeds, it gets cached locally, and everything works fine. If it fails immediately (e.g. network unplugged, or DNS server gives an immediate NXDOMAIN), the server's not entirely happy, but at least you can do things.

If the DNS lookup times out, you have to wait for it to time out over and over and over again every single time some part of the server software decides it'd be a good idea to check its hostname (or whatever it's doing). It'll appear frozen, but if you wait long enough it'll eventually let you do things, but every single step will require you to wait through one or more DNS timeout periods.

To check DNS resolution from the Mac, log in (unplugged from the net if necessary), open Terminal, plug the net back in, and run:

host [hostname]    # host queries DNS directly, bypassing the system resolver and cache
host [ipaddress]
dscacheutil -q host -a name [hostname]    # dscacheutil uses the system resolver and cache
dscacheutil -q host -a ip_address [ipaddress]

If any of those don't return immediately, your DNS is not working properly yet.

| improve this answer | |
  • when I write host [ipaddress] it say Host [backwards ip].in-addr.arpa. not found: 3(NXDOMAIN) When i type in dscacheutil -q host -a ip_address [ipaddress] it returns nothing can this be related to my problem? – Tomas Mar 20 '15 at 10:07
  • okay another mac server was doing the same thing, and it works, so that can't be an issue – Tomas Mar 20 '15 at 12:19
  • I'd still fix this -- OS X Server really wants to be able to find itself via reverse DNS, and not all functions will work properly if it's not set up. I'm also still not convinced this isn't the cause of the freeze. So humor me: fix the DNS, and see what happens. – Gordon Davisson Mar 20 '15 at 13:58
  • Okay I will, and get back to you – Tomas Mar 20 '15 at 19:50
  • Okay I got reverse lookup to work now, other than the dscacheutil -q host -a ip_address [ipaddress] command still returns an empty string, but it still freezes – Tomas Apr 10 '15 at 10:56
0

The problem was YP bind. it still thought that it should get the OD accounts from the old ip, so that was why it couldn't find them.

I deleted the file accociated with the domain in /var/yp/binding/ and restarted the system. The machine is now acting normal to ssh and logging in from gui.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.