BACKGROUND
I am one of three systems administrator for the organization i work at. We previously had a Java developer who is no longer with the organization. The developer built several custom Java apps that we use internally for client management among other things.
When the developer was here our organization operated in a Citrix environment. I do have some programming experience but i am not well versed in Java.

OUR ENVIRONMENT
We have 7 Citrix servers and our users use Citrix WebAccess to connect to these servers for all of their job functions. Their desktops are pushed using group policy on our domain controller. Everything in a user's day to day functions was/is done within this citrix environment which is essentially remote desktoping into our citrix servers. For storage of files we have a NAS connected to our network. We also have a SAN running on our network. Our Java classes and our Java sources are stored on our SAN which we named "dataserver".

PROBLEM
We are moving away from the Citrix environment because of a combination of limited staff and complexity of living a Citrix environment. The Java applications currently work in the Citrix environment but i cannot get the applications to load locally on a users machine. I have looked at the icon properties for the Java application's shortcut which reside on the desktop of users within our Citrix environment.


The following are the properties of the Java applications shortcut icon.
Target: C:\WINDOWS\system32\wscript.exe "R:\RM Programs\invisible.vbs" "R:\RM Programs\Social Enterprise\Social Enterprise Main Menu.bat"
Start In: "R:\RM Programs\Social Enterprise"
Shortcut Key: None
Run: Normal Window

From what i understand WScript is used to run VBscript files, and we are passing in the .vbs and .bat files.
I have looked at the contents of "invisible.vbs" and "Social Enterprise Main Menu.bat" and they contain the following.

INVISIBLE.VBS

CreateObject("Wscript.Shell").Run """" & WScript.Arguments(0) & """", 0, False

I really have no idea what this invisible.vbs file does

SOCIAL ENTERPRISE MAIN MENU.BAT

@echo off
net use Y: /delete /yes
net use Z: /delete /yes 
net use Y: \\dataserver\serenic_imports /persistent:no 
net use Z: \\dataserver\javacode /persistent:no 
java org/rmsyr/socialEnterprise/SocialEnterpriseMenu "socialEnterprise.dbo" "CounterPoint" "Z:/Templates/SocialEnterprise/" "Y:/SocialEnterprise/" "Y:/XML_Save/SocialEnterprise/" "V:/LabelPrinter/"  
net use Y: /delete /yes 
net use Z: /delete /yes 
exit 

I understand most of what this file does. Correct me if i am wrong.

1)I belive it is freeing up mapped drive letters Y and Z 2)I belive it is mapping Y and Z to the location mentioned above 3) Then it runs the SocialEnterpriseMenu and passes the parameters that are in the quotes - This step confuses me a bit because i have looked through out dataserver and have not been able to find the path "org/rmsyr/socialEnterprise/SocialEnterpriseMenu" 4) Finally, It removes the mapped drives

ATTEMPTED TO

The two files "invisible.vbs" and "Social Enterprise Main Menu.bat" reside on the SAN.
I have tried making a shortcut locally on the users machine and putting in the same parameters but that does not work. Nothing happens.
I have tried copying the files locally onto the the users desktop and putting a shortcut on the desktop that points to the local files but that did not work. Nothing happens.
I have tried pushing the shortcut to the user using Group Policy and pointing to the two files on the datasever but it does not work.

This kinda seems like a question that can live on both ServerFault and Stackoverlow. Does anybody have any ideas on what might be going wrong or how to fix it?
Or does anyone know how i should be deploying our In-House Java apps in our new Group Policy managed environment?

I forgot to mention our users desktops are Windows 8.1 The OS for our Citrix users is Windows XP On our Citrix server we currently have JRE 6U31 installed. This is the version i installed locally on the users machine.

Thanks in advance.

up vote 0 down vote accepted

You're misunderstanding this line.

java org/rmsyr/socialEnterprise/SocialEnterpriseMenu "socialEnterprise.dbo" "CounterPoint" "Z:/Templates/SocialEnterprise/" "Y:/SocialEnterprise/" "Y:/XML_Save/SocialEnterprise/" "V:/LabelPrinter/"

Java.exe is being called, to execute a Java class denoted as "org/rmsyr/socialEnterprise/SocialEnterpriseMenu", which will be in a java class file located in "R:\RM Programs\Social Enterprise" . The part that starts with "org" is not a file path.

From a workstation, map the R: drive to the same location as a Citrix user gets, CD into "R:\RM Programs\Social Enterprise", and run the BAT file there.

And (per your comment), since the developer says that CLASSPATH has to include the directory where the class files are, you have to configure that on the client workstations. If you have access to the developer and/or documentation, please please utilize those resources rather than just guessing.

  • I appreciate your help and clarification of my confusion. You ask that i map the R: drive then CD (change directory I am assuming from command prompt) into "R:\RM Programs\Social Enterprise then run the bat file. What i am confused about is the application should be executed from a shortcut on the desktop. Why/How would i be changing directory to "R:\RM Programs\Social Enterprise"? I think this is what should be in the start in field in the shortcut but i am not sure. Is that correct? – hfrog713 Mar 19 '15 at 17:16
  • It's already in the shortcut that your citrix users are using today, that's why you should continue using it. When you call java.exe as described, it depends on finding the class files in the current directory. – mfinni Mar 19 '15 at 17:25
  • Ok, thanks. I just have one more comment. The users mapped "R:" drive is currently mapped to "dataserver\rmresources" but the class files are not located there. I have found where the class files are located, they are located in dataserver\javacode\javaclasses\org\rmsyr\socialEnterprise. I had sent an email to the developer at some point and she had mentioned something about changing a classpath attribute on the server. Any idea what she may be talking about? Also because the class in not located in "R:\RM Programs\Social Enterprise" does this change anything about your answer. – hfrog713 Mar 19 '15 at 17:28
  • Listen - short story, the relevant parts of the client workstation environment have to match the Citrix environment. If that's working directory, or the CLASSPATH variable, or an LPT port, or a dongle, it matters, and it will be specific to the application you're talking about. So yes, if the developer says that CLASSPATH needs to include that directory, then do that. Edited my answer. – mfinni Mar 19 '15 at 17:48
  • I am just not sure where to change the classpath attribue? is that in the .bat file that i have to change it or is there a setting on the computer? – hfrog713 Mar 19 '15 at 18:06

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.