0

I'm having a problem accessing the data from a drive that was in my NAS but is now plugged in via a USB caddy. This drive was not in a RAID array as it was a volume with a single disk. Although it seems the synology (DS414) NAS might have used SHR when it constructed the volume. The drive was removed to make way for a larger drive to expand another volume. Now I would like to retrieve the data from this drive, but it appears to not be accessible.

When plugged in via a caddy the old drive is not recognized, although it does show up with fdisk -l

Disk /dev/sdq: 750.1 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sdq1               1         311     2490240  fd Linux raid autodetect
Partition 1 does not end on cylinder boundary
/dev/sdq2             311         572     2097152  fd Linux raid autodetect
Partition 2 does not end on cylinder boundary
/dev/sdq3             588       91201   727848912   f Win95 Ext'd (LBA)
/dev/sdq5             589       91189   727744480  fd Linux raid autodetect

I have tried using mdadm -A --verbose --run /dev/md4 /dev/sdq5 then mount /dev/md4 /mnt/usb but I get a simple no such device response.

The command cat /proc/mdstat returns

md4 : active raid1 sdq5[0]
      727743296 blocks super 1.2 [1/1] [U]

I've tried resize2fs commands as well to try and fix possible faults with the filesystem. I've also tried using sdq3. But none of this works.

Does anyone know how I can access the data on this single drive?

0

On thing that looks quite suspicious is the overlap of two partitions:

/dev/sdq3             588       91201   727848912   f Win95 Ext'd (LBA)
/dev/sdq5             589       91189   727744480  fd Linux raid autodetect

I assume you are wanting to access /dev/sdq5? What is the /dev/sdq3 entry doing?

Try using fdisk -l -u=sectors for a more precise view of the partitions.

Finally, please show us the output of fsck.

  • fdisk -ul doesn't give any more information, the partitions appear to overlap. I assume its how SHR (Synology hybrid raid) works. I don't know which one would be best to access, but I've had no luck with either. Also I cannot install fsck as I'm accessing the drive through the synology box and its cut down linux (busybox) does not have a package manager. – Coin_op Mar 20 '15 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.