0

EDITED 3/23: I've been trying to configure a DS/NPS->Sonicwall->Meru Controller>Client RADIUS Wifi solution and I haven't had much success on the sonicwall side. I've shortened all shared secrets to 8 characters(I heard that was an issue), and opened up ports 1812,1813 and confirmed ports 389 and 636 were open as well as enabling RADIUS on the Firewall itself.

Meru acts as the Point of Access for the wireless devices and is currently set to use Sonicwall as the RAD Accounting Server(the Authen server is still the DS). Sonicwall is acting as an intermediary between Meru and a server cohabitating NPS(with a wireless policy setup) and DS. The user accounts I've tried to sync with all are on the IAS Admin list as well as on Domain Admins. I’m a little iffy on the Sonicwall but here are my RADIUS settings:

Authentication Method: LDAP+Local Users

Under LDAP Server I have: Name or IP Address: My Domain Controller/NPS Port number 389 (for now to see that it works).

Give Login name/location in tree User: Administrator@domain Protocol:LDAP

No certificate, No TLS until I can get it to work. I’ll use TLS once it works.

Enabled LDAP Relay, with same shared secret

Upon testing with Domain/Administrator

It claims my credentials aren’t valid at LDAP server on some tests, and in others gives me a RADIUS Communication error.

UPDATE:

Alright, so the LDAP functionality of the RADIUS Accounting works now(I ended up using bind distinguished name), but RADIUS is still screwy. Everytime I try testing the RADIUS(and verified by the test SSID I have setup not working) I get what's known as a "RADIUS Authentication error on the Sonicwall side and on the Meru side I'm getting the following: Radius Server Switchover Information Controller SD-Radius-172.16.0.1 03/23/2015 13:14:02 Radius Server switches over from Primary <172.16.0.1> to Secondary <172.16.0.120> for Profile

"

Almost like the Meru Controller isn't seeing the Sonicwall.

  • 1
    Is your DS a Windows 2008 or 2012 Server? I have set up almost this exact setup and had to use the NPS logs to troubleshoot. I believe I ultimately forgot to add the SonicWALL IP as a RADIUS client in NPS. – armani Mar 20 '15 at 22:31
  • 2012. I have my main X0 network(which is currently my only LAN) set as a RADIUS Client on NPS. I figured out at least half of the Sonicwall part, in that I've gotten users to upload from the LDAP itself, although the RADIUS was problematic when I left to go home. If it's okay to continue in this Q/A thread I'll show the setup that so far has worked on LDAP User side, and give some of the config errors I'm running into with the relationship between the Sonicwall and Meru Controller when I get back on campus. Hopefully someone here has some insight into that wireless flavor. – nerdythor Mar 21 '15 at 1:37
  • @armani: How'd you get your system to work besides adding the clients to NPS? Is there a NAT or Routing rule I need to add to the sonicwall? – nerdythor Mar 23 '15 at 16:08
  • I'm pretty sure that was it, though honestly this was a couple years ago and I no longer work for that company. – armani Mar 23 '15 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.