I have a HP Proliant ML110 G5 (tower) which fails to boot whenever a large disk (4TB) is attached via USB. The machine displays the HP logo for a very long time (the POST on these machines is long anyway, but in this instance it can be 5 mins or more), then shows a black screen, then restarts (showing the HP logo again...)

I have not been able to check whether the system will boot when the disk is attached via SATA because the USB caddy enclosure is sealed and under warranty. The largest other disk attached to the system via USB is 3TB, the largest disk attached to the SATA controllers is 2TB.

I've checked the manuals, and the POST troubleshooting workflow, but none give any clues.

Does anyone please know if this range of Proliant servers should be able to handle these disks attached on boot, or if there is a setting in BIOS or the firmware which I have missed? I'm not keen to update the firmware (everything else works very well, and I can live with needing to remove the drive/buy a UPS for power outages), but if it is the only option I will try it.

  • Downvote? Is it a problem with the wording, the question or something else? – questions Mar 22 '15 at 19:36
  • Please specify the model and generation of your HP server. – ewwhite Mar 22 '15 at 20:25

This question doesn't quite make sense. Do you mean to say TB (Terabyte) instead of GB (Gigabyte)?

If the latter, I think the boot process is subject to the contents of the drive(s). This could be as simple as correcting your system boot order in the BIOS.

If this is the former, and you have large external disks attached to the server, have you tried the front and rear USB ports to observe the behavior? Depending on BIOS settings, the effect could be different based on the drive location.

You mention this is a ProLiant ML110 G5. That server is from ~2009, so it's long past its normal support lifetime. I think you'll get the most mileage by working with the BIOS configuration.

| improve this answer | |
  • 1
    Thanks, you're quite correct, the disk is indeed 4TB, apologies. Yes, I've tried it in both the front and back (and the single MOBO port). All cause the POST to fail. I've previously tried some BIOS configuration based upon forum searches, but the only option seems to be disabling USB or USB2.0 entirely. The boot order does specify Hard Disks over Removable Devices, but USB Caddy drives show up in the Hard Disks section. Further, because I can't get past the power on logo, I can't get into BIOS with the disk connected to the machine. Any ideas please? Thanks for your thoughts. – questions Mar 23 '15 at 11:45
  • Call HP at this point. – ewwhite Mar 23 '15 at 13:03

I think you answer may be found in this thread. The embedded G5 disk controller didn't support >2.2TB disks on the original firmware. You may wish to check for a firmware update for the controller. Based on the thread if the update is after 2010, it may fix the issue for you, but you should check the release notes for the update to be sure.

| improve this answer | |
  • The OP is talking about USB disks. – ewwhite Mar 23 '15 at 6:39
  • That's true - but something still has to control that disk - even if it is USB. – James Shewey Mar 23 '15 at 6:50
  • Interesting thanks- as you say something must control the disks, but there is also a 3TB disk connected in the same manner (via USB), and the machine is happy to start up and POST with that connected. It just seems to be this 4TB drive which causes it to balk. Perhaps the firmware has been updated previously, but could do with another. I'll check the current version and the available releases. Indeed, I think the machine fell out of it's support contract about 9 months ago but getting the cash unlocked to get a newer machine (which is really needed) is unlikely in the next 6 months at least. – questions Mar 23 '15 at 11:52
  • It may be more about partition size. If you have a 3 TB disk with two 1.5 TB partitions for the existing disk, you may not cause a problem, but If the new disk has a 3 TB partition that may be the issue. – James Shewey Mar 23 '15 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.