0

Alrighty...

So here's what's going on.

I can sign in with Outlook to my Mail Server, but when I go to send an email, I get this error. Using SquirrelMail, I don't get any errors, sending works fine. However for obvious reasons, I'm not going to use SquirrelMail.

Some files of potential interest are:

The mail.log:

Mar 20 18:55:56 mail postfix/smtpd[2809]: connect from mail-pd0-f202.google.com[209.85.192.202]
Mar 20 18:55:56 mail postfix/smtpd[2809]: warning: non-null host address bits in "104.236.240.12/24", perhaps you should use "104.236.240.0/24" instead
Mar 20 18:55:57 mail postfix/smtpd[2809]: Anonymous TLS connection established from mail-pd0-f202.google.com[209.85.192.202]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Mar 20 18:55:57 mail postfix/smtpd[2809]: warning: non-null host address bits in "104.236.240.12/24", perhaps you should use "104.236.240.0/24" instead
Mar 20 18:55:57 mail postfix/smtpd[2809]: NOQUEUE: reject: RCPT from mail-pd0-f202.google.com[209.85.192.202]: 451 4.3.0 <ethan@ebear.us>: Temporary lookup failure; from=<33y4KVRgKBRQ08805y-u99C-x8-78D-By95I08805y.w86yD1u7yvyuB.EC@gaia-hosted.bounces.google.com> to=<ethan@ebear.us> proto=ESMTP helo=<mail-pd0-f202.google.com>
Mar 20 18:55:57 mail postfix/smtpd[2809]: warning: non-null host address bits in "104.236.240.12/24", perhaps you should use "104.236.240.0/24" instead
Mar 20 18:55:57 mail postfix/smtpd[2809]: disconnect from mail-pd0-f202.google.com[209.85.192.202]

The main.cf

The resolv.conf:

nameserver 2001:4860:4860::8844
nameserver 2001:4860:4860::8888
nameserver 8.8.8.8
nameserver 8.8.4.4

So yeah, I have no idea what's wrong. By the way, the server I'm trying to send mail from is mail.ebear.us, MX records are configured correctly. Running Ubuntu 14.10

Thanks in advance for the help!

  • Did the error persist after you change it to /32 and restart postfix? If yes, please edit the question and post the output of postconf -n and postconf -M – masegaloeh Mar 22 '15 at 23:10
  • Ok. Here you go. postconf -n returned the following: pastie.org/10046140 and postconf -M returned: ebear.us/files/postconfm – Ebear Mar 23 '15 at 1:58
  • I've tried to telnet mail.eibar.us 25 and it already works. No more "Temporary lookup failure" error given – masegaloeh Mar 23 '15 at 2:16
  • Hmm... That's always worked, but now I'm getting an error that says this: pastie.org/10046312 Configuration is the same as when I last messaged. (Updating title and logs) – Ebear Mar 23 '15 at 2:34
  • Please ask the new question as this is new error message. You should also accept EEAA answer below as it fix your problem. See serverfault.com/help/someone-answers – masegaloeh Mar 23 '15 at 2:37
4

So, did you actually read the error message and try making the change it recommended?

From your main.cf:

mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 104.236.240.12/24

That last entry is invalid. If you want to specify a single host, use /32. If you want to specify that entire subnet, use 104.236.240.0/24.

  • Please post log messages that are relevant to the sending errors you're seeing - I don't believe the above messages are relevant. – EEAA Mar 22 '15 at 22:29
  • Fixed it, here you go: ebear.us/files/main.cf – Ebear Mar 22 '15 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.