3

Because of errors=remount-ro an underlying NFS blip caused my root mount to be remounted as read-only. I know there is nothing wrong I need to worry about. How can I remount this as rw without rebooting the server?

Some tests:

simon@steve:~$ sudo hdparm -r /dev/sda1

/dev/sda1:
 readonly      =  0 (off)
simon@steve:~$ sudo blockdev --setrw /dev/sda1
simon@steve:~$ sudo blockdev --setrw /dev/sda
simon@steve:~$ sudo hdparm -r /dev/sda1

/dev/sda1:
 readonly      =  0 (off)
simon@steve:~$ sudo hdparm -r /dev/sda

/dev/sda:
 readonly      =  0 (off)
simon@steve:~$ sudo mount -o remount,rw /
mount: cannot remount block device /dev/sda1 read-write, is write-protected
| improve this question | | | | |
3
mount -o remount,rw /mountpoint
| improve this answer | | | | |
  • 7
    This doesn't work with the error mount: cannot remount block device /dev/sda1 read-write, is write-protected – SimonJGreen Mar 24 '15 at 22:35
  • 3
    Then your system thinks the device is read only, it's not just the mount. I would look in the logs to see why this happened. You can also try setting the block device as read-write, then trying the mount. blockdev -setrw /dev/sda1; mount -o remount,rw /mountpoint. More info at: Linux, how to change HDD state from ReadOnly after temporarly crash? – yoonix Mar 24 '15 at 22:55
  • 1
    this hasn't worked either unfortunately. did some experiments from the site you linked and output is in original post – SimonJGreen Mar 25 '15 at 9:11
  • 1
    +1 for your profile update, tons of us feel the same way. – MDMoore313 Mar 27 '15 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.