2

I'm trying to set up HHVM for one of my websites. It is running on Apache 2.4, Ubuntu 14.04. I apologize for not being the most advanced system administrator, I am more in the software engineering end of the spectrum.

I've got HHVM installed when but when I use FastCGI for the entire Apache server, it breaks ownCloud. After a bit of reading, I find that the ownCloud developers are still in the process of getting it compatible with HHVM.

So I want to run just one directory with FastCGI and hence HHVM.

My website which I do want to run FastCGI for is in: /var/www/website A sub-directory in here is the document root as per:

DocumentRoot /var/www/website/www

(Some of the code lives above the document root for the website; classes, etc.)

ownCloud is in: /var/www/owncloud And has the configuration:

Alias /owncloud "/var/www/owncloud/"
<Directory "/var/www/owncloud">
    Options +FollowSymLinks
    AllowOverride All
</Directory>

I've tried quite a few things in apache2.conf without success.

ProxyPass / fcgi://127.0.0.1:9000/var/www
ProxyPass /owncloud/ //127.0.0.1:80/owncloud

­

ProxyPass /var/www/website/ fcgi://127.0.0.1:9000/var/www/website

­

ProxyPass /website/ fcgi://127.0.0.1:9000/var/www/website

­

<Directory /var/www/website/>
    SetHandler fastcgi-script
    SetHandler proxy:fcgi://127.0.0.1:9000
</Directory>

Any ideas?

0

So it seems like you wish to proxy things to your fast cgi process unless the URI starts /ownlcoud/. You just need to tell mod_proxy not to proxy the requests to /owncloud/. So you need to add

ProxyPass /owncloud/ !

before your proxy directive to your FCGI process. You can add other exclusions in the same way if you need to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.