0

I have a QNAP TS-879U-RP that is 2.5 years old (Firmware 3.7.1 Build 20120614), installed with 8 HDD (Seagate ST3000DM001-9YN1CC4H). I am having trouble accessing it after an unscheduled shutdown due to a power trip.

The problem started when I noticed that I am able to see all the folders in the NAS, but when I tried to access any one of the folders, I am unable to enter after trying to login.

In Volume Management, Drive 4 has a status of "Disk Read/Write Error", even though the SMART Information reads "GOOD". The LED on the bottom rightmost HDD is also red instead of green.

The System Event Logs said that the system was shut down 2 days ago and then started again yesterday. Right after it restarted, it says

[RAID5 Disk Volume: Drive 1 2 3 4 5 6 7 8] Raid device is inactive

I tried to do a "Recover" from the Raid Management, but it failed.

When I tried to check the Disk Usage from the Resource Monitor, nothing appears, i.e. nothing is selected for Volume, and Total/Used Size/Available space are all 0KB.

I then ran a "Bad Blocks Scan" on Drive 4, and now the status is "Ready" instead of the previous "Disk Read/Write Error". I then restarted the system, and now the system log says

[RAID5 Disk Volume: Drive 1 2 3 4 5 6 7 8] Add drive 2 to the volume failed
[RAID5 Disk Volume: Drive 1 2 3 4 5 6 7 8] The file system is not clean. It is suggested that you run "check disk"
[RAID5 Disk Volume: Drive 1 2 3 4 5 6 7 8] RAID device in degraded mode

In Volume Management, I see

RAID 5 Volume: Drive 1 3 4 5 6 7 8

where Drive 2 is missing, and Status is "In degraded mode". (Drive 2 has a status of "Ready" and SMART Information "GOOD" in Volume Management.) So I clicked "Check Now" in the Volume Management - > Logical Volumes and now it's performing the check. One thing to note is that now, while I can see the Disk Usage statistics in Resource Monitor (Volume: RAID 5 Disk Volume: Drive 1 3 4 5 6 7 8 0), I am unable to access the folders at all.

What can I do to resolve this problem?

ETA: @S.Haran I'm unfamiliar with RAID and linux tools for hard disk health checking. So I did the following and got the output below:

[~] # df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/ram                139.5M     99.4M     40.0M  71% /
tmpfs                    64.0M    120.0k     63.9M   0% /tmp
/dev/sda4               310.0M    230.4M     79.6M  74% /mnt/ext
/dev/md9                509.5M     90.5M    418.9M  18% /mnt/HDA_ROOT
/dev/md0                 18.9T      7.4T     11.5T  39% /share/MD0_DATA
tmpfs                    32.0M         0     32.0M   0% /.eaccelerator.tmp



[~] # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] 
md0 : active raid5 sda3[0] sdh3[7] sdg3[6] sdf3[5] sde3[4] sdd3[3] sdc3[2]
      20500882752 blocks super 1.0 level 5, 64k chunk, algorithm 2 [8/7] [U_UUUUUU]

md8 : active raid1 sdh2[2](S) sdg2[3](S) sdf2[4](S) sde2[5](S) sdd2[6](S) sdc2[7](S) sdb2[1] sda2[0]
      530048 blocks [2/2] [UU]

md13 : active raid1 sda4[0] sdh4[7] sdg4[6] sdf4[5] sde4[4] sdd4[3] sdc4[2] sdb4[1]
      458880 blocks [8/8] [UUUUUUUU]
      bitmap: 0/57 pages [0KB], 4KB chunk

md9 : active raid1 sda1[0] sdh1[7] sdg1[6] sdf1[5] sde1[4] sdd1[3] sdc1[2] sdb1[1]
      530048 blocks [8/8] [UUUUUUUU]
      bitmap: 1/65 pages [4KB], 4KB chunk

unused devices: <none>

My data should be on /dev/md0.

I think smartctl isn't installed on my NAS, although the Volume Management page indicates SMART Information "GOOD" for all the drives. Is it ok if I install smartmontools on my NAS?

1

If your RAID5 is running in degraded mode it should allow access to your data. But since it doesn't I suspect the problem may be at the filesystem level.

Try and ssh into the QNAP and see if your data volume is mounted or not.

The QNAP uses Linux Software RAID aka mdadm. To gather info take a look at /proc/mdstat and do some mdadm --examine's on the RAID member data partitions. Also check the drive's SMART info with smartctl, you may be dealing with failing drives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.