1

Debian Server Setup (wheezy)

1 - eth0 - Connected to INTERNET
1 - eth1 - LAN 1 (Network 1 : 192.168.100.0/24)
1 - wlan0 - Access Point (Network 2 : 192.168.200.0/24)

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static
     address 192.168.100.1
     network 192.168.100.0
     netmask 255.255.255.0
     broadcast 192.168.100.255
     gateway 192.168.100.1

auto wlan0
iface eth0 inet static
     address 192.168.200.1
     network 192.168.200.0
     netmask 255.255.255.0

/etc/default/isc-dhcp-server

INTERFACES = "wlan0" 

/etc/dhcp/dhcpd.conf

subnet 192.168.100.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    pool {
        range 192.168.100.50 192.168.100.60;
    }
    option routers 192.168.100.1;
}

subnet 192.168.200.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    pool {
        range 192.168.200.50 192.168.200.60;
    }
    option routers 192.168.100.1;
}

From the above configuration, I get an error from dhcp; and if by chance, only the clients connected to WLAN0 gets ip-lease;

Please help.

  • 2
    Can you edit your question with the right formatting, and explain what you're actually trying to do, and what you tried? – Halfgaar Mar 25 '15 at 9:03
  • Don't use pool { ... };, just use range { ... }; and add eth1 to the INTERFACES line. – wurtel Mar 25 '15 at 9:11
0

I think you should modify you /etc/default/isc-dhcp-server from

INTERFACES = "wlan0"

to

INTERFACES = "wlan0 eth1"

then restart your server. So you can avoid error and your dhcp server can serve 2 networks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.