0

I've got a server with two network cards. The first one is configured with an internal IP and everything works just fine. The second one is configured with an external IP and is causing me some trouble: if I try and reach that address from inside the network everything is fine, if I try and reach that address from outside the network there's no way I can access the service on that server.

A traceroute from outside the network stops when reaching the gateway of the second network card. There must be something wrong either in the server configuration or in the gateway one, but I only have access to the server (and the gateway should be fine): what can I do to make sure that my configuration is correct?

Thank you, I'll provide any further information that can help you help me.

  • 2
    Does the second NIC have the correct Default Gateway configured? – joeqwerty Mar 25 '15 at 15:33
  • The first NIC has the correct internal gateway, the second one has the correct external gateway (the one where the external requests stop). – Edoardo Maria Elidoro Mar 25 '15 at 18:18
  • What operating system is this server running? – joeqwerty Mar 25 '15 at 18:20
  • Ubuntu, I'm checking if it's a default gateway problem as @Rex said. – Edoardo Maria Elidoro Mar 25 '15 at 18:51
0

Your default gateway on the server will need to point to the outside gateway.

This may cause you to lose access to the external IP from your internal networks. Without knowing more about your network and configurations, it's hard to say for sure if this will happen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.