2

In a new installation of SQL Server 2012 Standard, we have mixed-mode authentication enabled. Using Windows authentication, I can authenticate and use SQL Management Studio as expected. Using SQL authentication, SQL Management Studio will not let me authenticate. Two strange symptoms:

  • Typing in the password field on the SQL Management Studio 'Connect To Server' dialog has a long lag of about 3 seconds per character typed
  • Authentication fails, even though the password is entered correctly

I am certain that we are using the correct password, and we can authenticate successfully using the same SQL credentials from other applications. I have tried switching network protocols, using server aliases, but the problem appears to be in SQL Management Studio.

  • 1
    did you get to the bottom of this? – Martin Dec 24 '15 at 11:25
  • 1
    I solved this problem, but this site wont let me answer the question, So I have to do a comment instead, go to regedit and add this: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb] "ProtectionPolicy"=dword:00000001 You may have to reboot your server – trampster Feb 14 '17 at 0:38
0

Start checking your computer.

Seriously. I stopped looking at anythingelse the moment you wrote:

Typing in the password field on the SQL Management Studio 'Connect To Server' dialog has a long lag of about 3 seconds per character typed.

This is NOT normal. Period. Whatever else is a problem, I would start reinstalling the computer for the fear of malware or something like that right here.

0

First check and see if the SQL Server User have proper permissions, database mappings.

If yes then try the following:

  • Open SQL Management Studio
  • Login in with windows authentication
  • Change SQL server authentication username/password
  • Now Try logging in using the newly changed sql server credentials if this fails repeat the process by signing it first with SA credential and editing creds for the sql server user.
0

Try adding/changing the DNS Server setting to local DNS (instead of Internet DNS, like Google's 8.8.8.8) on your Network Setting. See if it works.

protected by Community Oct 8 '15 at 17:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.