5

Dear people of the world.

I have a problem reattaching an iSCSI target on XenServer after a reboot.

Whenever I try, I get several errors. Here's me in the attach screen on the redundant storage after it failed to reconnect: http://i.imgur.com/jkBYI1g.png

So it found the Target IQN and Target LUN, but after I click on Finish, I get the following error:

Scanning for LVM over iSCSI SRs on 192.168.3.1

Logging in to the iSCSI target failed. Check your username and password.

Check your settings and try again.

Funny thing is that I disabled CHAP on the Target in Synology.

Even after removing the storage in Xen, then trying to connect again, the same error.

If I disable multipathing I can attach it just fine. But if I enable multipathing, I get the errors. Does anyone know why?

1

Have you granted your servers access to the LUN's from the SAN? For my SAN I had to log into the management console, create a hostgroup (ex: named it 'blade-servers'), mapped the necessary LUNs to the hostgroup then added each individual server as a host to the host group. I could see the ISCSI IQN for each server I wanted to allow access to my LUNs.

But you're environment could be entirely different. What kind of SAN are you working with?

| improve this answer | |
1

@Refalm, @jrd1989, each interface on the initiator has to be allowed access on the target. A single machine with two different pathways to the same target requires two different ACL entries. An ACL entry can exist that is solely based on iqn, but not have CHAP. Further CHAP can be used in the discovery phase and connection phase.

| improve this answer | |
1

From what I can see, the only reason why this happens is that Multipathing isn't enabled on both Synology and XenServer sides.

Here's this option in Synology https://www.synology.com/_images/tutorials/use_port_binding_to_configure_multipath/1.jpg

And the Multipathing configuration guide in Xen https://docs.citrix.com/content/dam/docs/en-us/xenserver/xenserver-61/xs-design-iSCSI-multipathing-config.pdf

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.