Since upgrading to LXC 1.0 with the new Arch Linux template when I create a new instance I have a double tty when invoking:

 lxc-console --name <container>

This is the output:

Arch Linux 3.19.2-1-ARCH (lxc/tty1)

arch1234 login:
Arch Linux 3.19.2-1-ARCH (pts/0)

arch1234 login:

When I enter the username and password the two tty's get in each others way.

The lxc container configuration is configured as follows:

# Template used to create this container: /usr/share/lxc/templates/lxc-archlinux
# Parameters passed to the template: -P vim,openssh
# For additional config options, please look at lxc.container.conf(5)
lxc.utsname = arch1234
lxc.network.type  = veth
lxc.network.link  = lxcbr0
lxc.network.flags = up
lxc.rootfs = /var/lib/lxc/arch1234/rootfs
lxc.mount.fstab  = /var/lib/lxc/arch1234/fstab
lxc.arch = x86_64
#lxc.include = /usr/share/lxc/config/archlinux.common.conf
lxc.cgroup.devices.deny = a
lxc.cgroup.devices.allow = c *:* m
lxc.cgroup.devices.allow = b *:* m
lxc.cgroup.devices.allow = c 1:3 rwm
lxc.cgroup.devices.allow = c 1:5 rwm
lxc.cgroup.devices.allow = c 1:7 rwm
lxc.cgroup.devices.allow = c 1:8 rwm
lxc.cgroup.devices.allow = c 1:9 rwm
lxc.cgroup.devices.allow = c 4:1 rwm
lxc.cgroup.devices.allow = c 5:0 rwm
lxc.cgroup.devices.allow = c 5:1 rwm
lxc.cgroup.devices.allow = c 5:2 rwm
lxc.cgroup.devices.allow = c 136:* rwm

The fstab contains:

sysfs sys sysfs defaults 0 0
proc proc proc nodev,noexec,nosuid 0 0

Possible that it has something todo with systemd running inside the container which is not configured properly.


I've encountered the same issue. The workaround I've found is to disable getty@lxc-tty1.service in the container:

lxc-attach -n arch1234 -- systemctl disable getty@lxc-tty1.service
lxc-attach -n arch1234 -- systemctl stop getty@lxc-tty1.service

Try this workaround:
lxc-console -t 0 -n <container>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.