0

System Info: I have an Active Directory domain controller, Windows 2012r2, running DNS, and acting as a DHCP Server. In the domain I have four Apple Mac OS X client systems (running Yosemite, 10.10.2) bound to Active Directory - all these clients are cabled, one is wifi. The Windows clients do not experience DHCP anomalies.

Issue: Sporadically (perhaps once a day) on one of the Apple systems (refraining from using the word "Mac" to avoid confusion with the issue), the DHCP server displays the Unique ID (i.e. MAC address) as an incorrect . I'm beginning to suspect that the problem is due to the Apple systems running Windows VMs in bridged mode.

When the DHCP issue occurs, sometimes it is either guest or host OS (or both) that display wrong MAC addresses on the DHCP server. The issue is presented as a MAC address that is 18 digits long (example: 4e4c4f464649454341). Sometimes the addresses even have less digits than the standard MAC address. My research indicates that these values are sent in the DHCP request from the client to the server.

When the issue occurs, the DHCP server still assigns the host and/or guest IPs normally, however I really need to have the MAC addresses submitted correctly, since I have implemented DHCP policies on the server which require specific IP ranges, DNS settings, etc. So the policies aren't applied when this problem appears. Bridged networking is also a must due to GPOs that need to be applied to the guests OS on the Win side. I also want to avoid forcing 8 systems to static IP leases too...

Troubleshooting Done So Far: I have confirmed that MAC addresses on the guest Win7 systems are defined properly. I have also confirmed that the host Apple systems are using the NIC established, physical MAC address. I have confirmed that no rogue DHCP servers are on the network. I've tried deleting the bad leases/addresses from the server, refreshed DNS caches, tried various lease times, server reboots, only to see the problem appear again in the future or even minutes later.

A note on DHCP mismatches: https://www.net.princeton.edu/announcements/dhcp-cliid-must-match-chaddr.html

I'm at a loss as to what could be causing this. (?)

0

I discovered the cause of the issue on the client system's TCP/IP configuration. The area for correction is located here on a MacOS system:

System Preferences > Network > Advanced > TCP/IP tab > DHCP Client ID field

Previously, I had input the hostname of the computer in this field. I removed it, and the erroneous MAC addresses stopped associating with the leased machines on the DHCP server. It appears the hostname for the Active Directory network is pulled from the file sharing (i.e. "Sharing") System Preferences on the Apple computers.

More useful Mac OS X & DHCP configuration for Windows networking info is located here: https://www.net.princeton.edu/mac/network-config-x/tcpip-enet.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.