0

I have a new Centos 7 system and having a trouble with cron jobs not runnning at the specified time:

[root@media cron.d]# cat /etc/cron.d/rsnapshot
30 02 * * * root       /bin/rsnapshot daily
00 02 * * 0 root       /bin/rsnapshot weekly

But in the logs:

[root@media cron.d]# cat /var/log/cron | grep rsnapshot
Mar 29 03:00:01 media CROND[17452]: (root) CMD (      /bin/rsnapshot weekly)
Mar 29 03:00:11 media CROND[17481]: (root) CMD (      /bin/rsnapshot daily)

I don't think it can be a time zone issue as it is the relative timing between the entries that is a problem - they should be executed with 30 minutes between them not with 10 seconds.

I can only assume it is something to do with systemd/anacron or some other new stuff. I am running centos 7 with the default settings (I haven't installed or removed anything to do with cron).

EDIT: Just realised it could have been due to the time change - but I thought that should switch 1AM to 2AM so not sure why the jobs would run together

  • I think your edit is "the answer" DST is applied at 2am - i.e. 2am became 3am last night. – AD7six Mar 29 '15 at 12:14
  • I guess so - but still unexpected. I'm in Europe and I think the official change is 1AM - 2AM. – robince Mar 29 '15 at 12:17
  • 1
    No, it was from 2:00am to 3:00am – faker Mar 29 '15 at 12:21
  • 3
    Can we vote here at Serverfault to stop using daylight saving time? If we all stick together, we can force the world out of this nonsense by preventing it to happen on every system on this planet. – Esa Jokinen Mar 29 '15 at 12:28
  • 2
    Can we all just run our servers on UTC and avoid this mess? – Michael Hampton Mar 29 '15 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.