5

When attempting to flash my LSI SAS 9211-8i card on my ASUS H87I-PLUS LGA 1150 Intel H87 Mini ITX Motherboard, I was able to get through all of the instructions until I was finally ready to flash, using SAS2FLSH.exe. The error reported was:

ERROR: Failed to initialize PAL. Exiting program.

What would cause this?

| improve this question | | | | |
6

Hit my head against the wall (a lot) on this. For me, solved it by:

More instructions here to compare: http://brycv.com/blog/2012/flashing-it-firmware-to-lsi-sas9211-8i/

| improve this answer | | | | |
  • 1
    This is already mentioned in the blogs, but for anyone else... the USB drive doesn't need to be bootable with Freedos. You should be able to open any FAT USB drive in the EFI shell. Your guide saved me a lot of time - thank you so much!! – Peter Valadez May 2 '18 at 0:43
  • in case my edit doesn't get approved: updated links (Shell_full.efi, sas2flash.efi) & where to place the Shell_Full.efi so it works on current supermicro boards (/efi/boot/bootx64.efi). also added reason of error. also note that sas2flash.efi doesn't work with newer efi shells. – bernstein Apr 8 at 19:25
  • also note that you can update the firmware from windows & linux as well. just not cross-flash it from IR to IT (and vice-versa) – bernstein Apr 8 at 19:33
2

Update and to know the reason:

Reason:

i cite from http://brycv.com/blog/2012/flashing-it-firmware-to-lsi-sas9211-8i/ : "I booted from the SD card and attempted to run sas2flsh but was met with an error: “ERROR: Failed to initialize PAL. Exiting program.” Fortunately, article 16266 mentions the error at the end and directs you to article 15807. The gist of article 15807 is that Intel 3000 or 5000-based boards have optionROM limitations which cause the above error. The easiest solution is to use a different system. Alternately, you can use the UEFI installer."

Update:

The sas2flash.efi ist now available from Broadcom The files on the LSI web page is no longer available. E.g. search for the file installer_p12_for_uefi.zip or using the Link.

Current Version: installer_p20_for_uefi.zip

Thanks to aronchick for the hint to sas2flash.efi !!

| improve this answer | | | | |
1

I ran into the exact same problem with updating the LSI SAS 9211-8i ("Failed to initialize PAL"), and found an unlikely solution: A firmware update was possible from within the MegaRAID Storage Manager running under Windows, there's a link "Update firmware" right on its dashboard.

| improve this answer | | | | |
0

After hours struggling with this error I was finally able to do it booting off a Windows 10 USB and went into Repair / Advanced / Commandline and was able to run the dos commands to update the card.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.