I have followed all the official istructions listed here:

official page

In detail, i have done:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7F0CEB10

(seems ok)

echo "deb http://repo.mongodb.org/apt/ubuntu "$(lsb_release -sc)"/mongodb-org/3.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.0.list

(seems ok, as the file /etc/apt/sources.list.d/mongodb-org-3.0.list is created with the right entry)

sudo apt-get update

(seems ok, as i see the repos in the list)

but when i do :

sudo apt-get install -y mongodb-org

it always says "Can't find package mongodb-org".

If i do:

sudo apt-get install -y mongodb

It works, but it doesn't install version 3.0 but version 2.4

I have tried multiple times to install 3.0 after removing / purging the 2.4 version, but with the same result: "Can't find package mongodb-org"

How can i install version 3.0 ?


apt-cache search mongodb doesn't find anything regarding mongodb-org

This is the content of /etc/apt/sources.list.d/mongodb-org-3.0.list :

deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse

these are the lines resulting from apt-get update regarding mondodb:

Ign http://repo.mongodb.org trusty/mongodb-org/3.0 InRelease
Trovato http://repo.mongodb.org trusty/mongodb-org/3.0 Release.gpg
Trovato http://repo.mongodb.org trusty/mongodb-org/3.0 Release
Trovato http://repo.mongodb.org trusty/mongodb-org/3.0/multiverse i386 Packages
Ign http://repo.mongodb.org trusty/mongodb-org/3.0/multiverse Translation-it_IT
Ign http://repo.mongodb.org trusty/mongodb-org/3.0/multiverse Translation-it
Ign http://repo.mongodb.org trusty/mongodb-org/3.0/multiverse Translation-en 

I'am running on Ubuntu 14.04 LTS 32 bit. Maybe the repo is only for x64? If it's the case, how can i install mongodb 3.0 on a 32 bit machine ? (i haven't seen anything regarding this dinstinction in the docs )


So, it seems there are no 32 packages in those repos. Now, where can i find them? I think it's stange as the docs ( official docs ) specify only this repo, and nothing is said about 32/64 bit differences.

  • 1
    Does apt-cache search mongodb find your package? Maybe it has another name? Mar 30 '15 at 14:56
  • Please post the contents of the file /etc/apt/sources.list.d/mongodb-org-3.0.list as well as the line from apt-get update showing this repo being checked? The repo contains the mongodb-org meta-package for x64 Trusty, as seen here: repo.mongodb.org/apt/ubuntu/dists/trusty/mongodb-org/3.0/…
    – Hyppy
    Mar 30 '15 at 15:25

There are no 32 bits packages in those repositories:

Check for yourself, amd64:

wget -O - \
  http://repo.mongodb.org/apt/ubuntu/dists/trusty/mongodb-org/3.1/multiverse/binary-amd64/Packages.gz \
  2>/dev/null | zless | grep ^Package
Package: mongodb-org-unstable
Package: mongodb-org-unstable-mongos
Package: mongodb-org-unstable-server
Package: mongodb-org-unstable-shell
Package: mongodb-org-unstable-tools

Whereas for i686, no packages are returned.

wget -O - \
  http://repo.mongodb.org/apt/ubuntu/dists/trusty/mongodb-org/3.1/multiverse/binary-i386/Packages.gz 2>/dev/null

Or if you prefer clicks, open a browser to that location:

xdg-open http://repo.mongodb.org/apt/ubuntu/dists/trusty/mongodb-org/3.1/multiverse/binary-i386/

Also, check this one.

Moreover, the vendor discourages the use of 32 bit binaries for production use, probably due to its limitations:

For production deployments, always run MongoDB on 64-bit systems.

  • i know the limtations: in fact in production and test we have a 64 bit machine. I need to install mongo 3.0 in my 32 bit develop machine ( i can't install 64 bit SO as guest in my virtual machine due to hardware limits )
    – Moppo
    Mar 31 '15 at 8:45
  • Well, if you are forced to use a machine incapable of running a 64bit VM that is required to do your job properly, you should raise this concern with your manager. That or ...
    – dawud
    Mar 31 '15 at 9:24
  • No, this is my personal develop machine. I don't have a manager :) The fact is i'd like to know if it's possible or not to install mongo 3.x on a 32 bit machine. If it's possible (as it seems from the docs) i'd like to know if there is a repo to fetch the packages from. If it's not possible i'm going to evalutate what to do
    – Moppo
    Mar 31 '15 at 9:29
  • Then you are your manager. Argument still holds.
    – dawud
    Mar 31 '15 at 9:31
  • I've searched with no success for 32 bit repos, so i accept your answer as the most helpful. Thanks.
    – Moppo
    Apr 1 '15 at 7:08

based on mongdodb docs you can try to install the tarball installation. That is (taken from the docs):

  1. download the binary files here or using curl -O https://fastdl.mongodb.org/linux/mongodb-linux-i686-3.0.6.tgz
  2. extract the files tar -zxvf mongodb-linux-i686-3.0.6.tgz
  3. copy extracted files

    mkdir -p mongodb
    cp -R -n mongodb-linux-i686-3.0.6/ mongodb
  4. add it to PATH

    #example in ~/.bashrc
    export PATH=<mongodb-install-directory>/bin:$PATH

note as noted in mongodb using this method will have some limitation

"This 32-bit legacy distribution does not include SSL encryption and is limited to around 2GB of data. In general you should use the 64 bit builds."

but in the end it is up to you.

  • This is the most accurate answer as it actually answers the OP's question. Jul 16 '19 at 2:47
echo "deb http://repo.mongodb.org/apt/ubuntu "$(lsb_release -sc)"/mongodb-org/3.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.0.list

Add the repository using the above code. Then run update command

sudo apt-get update

And then give a command to install mongodb giving all the parameters forcefully yes using

sudo apt-get install --force-yes mongodb

I hope this helps.

  • If you read the question you will see that he already tried that. May 7 '15 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.