3

A PC running Windows 7 can't access a file share in Windows Server 2008 by name (\\servername), but can access it by IP address (\\serverip). I get the error (Network path was not found). Also, all other PCs can access that server's shares by name just fine.

I had this problem before, but with different client PCs, and that seemed to be solved by restarting the server; this one seems like a permanent issue.

  • They're both in the same domain
  • The server is not a DC in this domain
  • They both use the same DNS server; the server is not a DNS server

Things I've tried:

  • Pinging the server by name; name resolution seems to work fine
  • Accessing the server by its FQDN (\\servername.domain.com); that fails too
  • Deactivating both firewalls

I'm not sure what to try next.

1
  • 2
    1. What nslookup returns? 2. try disabling the DNS service on the client and see what happens. – EliadTech Mar 31 '15 at 12:21
1

There might be 'share name' renamed. I think you have the permissions to access the resource that's why you can access the share not by share name but by IP address. Please check in the share name.

0

When you can get access via the IP but not the name, it may be a sign that Kerberos auth is failing, and it is falling back to NTLM for authentication.

  1. It sounds like you're saying all other workstations are okay, and only this one is affected?

  2. Does the workstation in question have a valid domain account?

  3. Can this worstation access other file servers okay?
  4. Does the SPN (service principal name) for the bad workstation look like the SPN for a functioning workstation (SETSPN -L workstationname)?
  5. Are there any duplicate SPN's for the workstation in question? (SETSPN -X) reports all duplicate SPN's.
  6. There are no entries for the server in question within the hosts file on the workstation?
  7. Does a different user on the same workstation still have a problem?

If none of this turns up anything, try removing the workstation from the domain and re-joining it.

0

Had the same issues with her file servers not been accessible on some machines

What we did what to add the suffix of the FQDN name on the DNS settings of the specific machines. i.e \servname.contonso.com

We added the contonso.com to the DNS settings of the affected machines. So you go to Network adapter settings of the machine. Select ipv4 properties of the adapter and under DNS change the settings by adding the suffix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.