1

I recently set up a new file share on a new server for Folder Redirection for a subset of our users. I robocopied the files, applied the policy last week, replacing the old policy, tested with a few users, and all seemed well.

This week, I'm hearing that some users are getting an error that they can't connect to \oldserver\users$\jsmith\desktop, where folder redirection SHOULD be pointing them to \newserver\users$\jsmith\desktop

I've attempted to clear out C:\ProgramData\Application Data\Microsoft\Group Policy\History on each machine, but we're a university and the quantity of users and computers is fairly large. Unfortunately, even after doing so, I've heard that the issue has persisted in one computer lab.

I even had someone reboot all the machines this morning, thinking that a reboot would force a policy refresh.

gpupdate /force seems to fix the issue, so it appears to be a stale cached GPO.

So - My questions are these:

  • By default, how long are group policies cached? Where is this setting?
  • How can I fix this WITHOUT telling my users to run gpupdate /force? It needs to work when they log in, without them needing to take a step and then log out/back in (preferably, of course!)
  • gpupdate /force only seems to update policy for logged in users (https://technet.microsoft.com/en-us/library/jj134201.aspx). Even if I run this, does this mean I need to catch it failing in the act?

(Offline files is disabled. Unfortunately, that's the only type of caching noted here: https://technet.microsoft.com/en-us/library/cc739647(v=ws.10).aspx)

0

My first usual suspect would be a bug in the Windows client. GPO's may not be re-applied unless the client detects that they have changed or if not on a slow link.

You may want to test if the following setting helps:

Computer > Policies > Administrative Templates > System > Group Policy: Folder Redirection Policy Processing

Note this is a computer setting, and may need to be in a GPO separate from the Folder Redirection GPO.

enter image description here

|improve this answer|||||
  • Thanks Greg! This is a good setting I hadn't seen before. It turns out, my specific issue was caused by group policy loop back being set to replace. You pointing at this setting caused me to review other computer settings that we're getting in the way. Thanks! – SteadH Apr 2 '15 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.