2

I have forwarded my IP using Google Domains to a specific URL. But when I access that URL it gets forwarded to my IP. Why is the url not showing up in my browsers address bar? I am running Ubuntu 14.04. The website is Wordpress site but this issue occurs even when I am using a simple index.html file.

  • What is the domain in question? – EEAA Apr 1 '15 at 2:50
  • I would post my domain here but that will make my IP publicly visible. – Dikshant Adhikari Apr 1 '15 at 2:51
  • Done. What other information might be helpful that I could provide? – Dikshant Adhikari Apr 1 '15 at 2:55
  • Why are you using forwarding instead of just pointing your URL to the IP address of your apache server? – EEAA Apr 1 '15 at 3:11
  • What file do I edit to do so? – Dikshant Adhikari Apr 1 '15 at 3:24
3

You have not redirected your IP to your domain, you have done the opposite:

$ wget -O/dev/null www.mindofmetadata.com 
--2015-04-01 14:10:31--  http://www.mindofmetadata.com/
Resolving www.mindofmetadata.com (www.mindofmetadata.com)... 2404:6800:4008:c02::79, 74.125.203.121

So your domain currently resolves to the above IPv4 and IPv6 addresses -- Google.

Connecting to www.mindofmetadata.com (www.mindofmetadata.com)|2404:6800:4008:c02::79|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://69.140.87.208 [following]

We connect to Google's servers and request your site. Google returns a "302" HTTP status code ("found").

--2015-04-01 14:10:32--  http://69.140.87.208/

This is where the "302" that the Google servers returns points us to -- the IP address of your server.

You need to adjust your configuration in your Google Hosted account. Or better, just point your domain directly to your IP Address and save the 302 redirect from Google.

| improve this answer | |
  • Well from the settings I can see at my dashboard atleast according to google the domain is forwarded. imgur.com/2udGIXS But where exactly do I edit my config to tell my server to direct my domain to the ip? – Dikshant Adhikari Apr 1 '15 at 3:16
  • It says clearly right there that your domain "is forwarded to http://69.140.87.208/". How to change that I don't know; you'll have to ask Google. – fukawi2 Apr 1 '15 at 4:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.