3

I have a Debian VM running which uses quite a bit of CPU time in ksoftirqd. I have other servers running Ubuntu (both 12.04/14.04) that do not have this same issue at all and may have to migrate back to Ubuntu if I can't figure out why this happens with Debian.

Output from Top (sorted by time)

top - 08:24:49 up 11:44,  1 user,  load average: 0.32, 0.14, 0.13
Tasks: 102 total,   2 running, 100 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.4 us,  0.0 sy,  0.0 ni, 99.6 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
MiB Mem:  2003.797 total, 1031.148 used,  972.648 free,   27.559 buffers
MiB Swap: 4092.996 total,    0.000 used, 4092.996 free.  766.535 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
   13 root      20   0    0.0m   0.0m   0.0m S  16.0  0.0  31:08.33 ksoftirqd/1
    3 root      20   0    0.0m   0.0m   0.0m S   2.3  0.0  23:28.20 ksoftirqd/0
  497 webapps   20   0 1128.5m  67.6m  14.8m S   0.0  3.4   3:09.39 python3
    7 root      20   0    0.0m   0.0m   0.0m S   1.5  0.0   2:16.28 rcu_sched
  496 webapps   20   0  127.0m  43.4m   9.0m S   0.8  2.2   1:29.28 celery
  879 root      20   0    0.0m   0.0m   0.0m S   0.8  0.0   1:24.55 kworker/1:2
  454 redis     20   0   37.6m   4.0m   2.3m S   0.0  0.2   1:08.58 redis-server
  826 root      20   0    0.0m   0.0m   0.0m R   0.0  0.0   1:00.38 kworker/0:1
  472 www-data  20   0   89.7m   4.5m   2.8m S   0.0  0.2   0:27.94 nginx
  490 root      20   0   56.0m  12.6m   3.6m S   0.0  0.6   0:26.24 supervisord
   11 root      rt   0    0.0m   0.0m   0.0m S   0.0  0.0   0:05.86 watchdog/1
  487 postgres  20   0  364.7m  20.5m  19.1m S   0.0  1.0   0:05.17 postgres
  486 postgres  20   0  364.7m   6.6m   5.2m S   0.0  0.3   0:04.68 postgres

Output from /proc/interrupts

            CPU0       CPU1
   0:     772416          0   IO-APIC-edge      timer
   1:          9          0   IO-APIC-edge      i8042
   6:          3          0   IO-APIC-edge      floppy
   8:          0          0   IO-APIC-edge      rtc0
   9:          0          0   IO-APIC-fasteoi   acpi
  12:        161          0   IO-APIC-edge      i8042
  14:          0          0   IO-APIC-edge      ata_piix
  15:      41523          0   IO-APIC-edge      ata_piix
 NMI:          0          0   Non-maskable interrupts
 LOC:    1447155    1235282   Local timer interrupts
 SPU:          0          0   Spurious interrupts
 PMI:          0          0   Performance monitoring interrupts
 IWI:          0          0   IRQ work interrupts
 RTR:          0          0   APIC ICR read retries
 RES:     109019     174764   Rescheduling interrupts
 CAL:       6495        376   Function call interrupts
 TLB:        308        185   TLB shootdowns
 TRM:          0          0   Thermal event interrupts
 THR:          0          0   Threshold APIC interrupts
 MCE:          0          0   Machine check exceptions
 MCP:        142        142   Machine check polls
 HYP:    1613643      15969   Hypervisor callback interrupts
 ERR:          0
 MIS:          0

Is this a normal for Debian on Hyper-V? If not how to I find out what is causing this and resolve it? Is it Hyper-V settings and not Debian?

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.