This question might be very unprofessional but I'm very not into Ruby and I have no clue where to start..

I used to run Jekyll which runs asciidoctor to render html pages.

After a Fedora update unfortunately I just get the message

$ jekyll serve
Conversion error: Jekyll::Converters::AsciiDocConverter encountered an error while converting '<some file>':
                  asciidoctor: FAILED: required gem 'pygments.rb' is not installed. Processing aborted.

I tried to install pygments.rb (as current user and/or as root) this way:

gem install pygments.rb

But it's already installed. When I remove it (in order to reinstall it) I get a hint:

$ gem uninstall pygments.rb

You have requested to uninstall the gem:

When I then try to run Jekyll/asciidoctor the message looks different:

$ jekyll serve
/usr/share/rubygems/rubygems/dependency.rb:298:in `to_specs': Could not find 'pygments.rb' (~> 0.6.0) among 72 total gem(s) (Gem::LoadError)
    from /usr/share/rubygems/rubygems/specification.rb:1295:in `block in activate_dependencies'
    from /usr/share/rubygems/rubygems/specification.rb:1284:in `each'
    from /usr/share/rubygems/rubygems/specification.rb:1284:in `activate_dependencies'
    from /usr/share/rubygems/rubygems/specification.rb:1266:in `activate'
    from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:54:in `gem'
    from /usr/local/bin/jekyll:22:in `<main>'

So in this case Jekyll seems to miss pygments.rb while in the other case (when pygments.rb is installed) it looks like asciidoctor is complaining.

Can you give me a hint where I should start to investigate?

  • Did you try to reinstall Jekyll as well?
    – 030
    Apr 1, 2015 at 20:36
  • I did now. With no effect I'm afraid. I'm still getting asciidoctor: FAILED: required gem 'pygments.rb' is not installed. Processing aborted.
    – frans
    Apr 1, 2015 at 20:41
  • What OS are you using?
    – 030
    Apr 1, 2015 at 20:42
  • It's Fedora 21 server edition. ruby 2.1.5p273 with jekyll-2.5.3 pygments.rb-0.6.3 and jekyll-asciidoc-1.0.0 installed
    – frans
    Apr 1, 2015 at 20:45

1 Answer 1


Make sure you have the python-pygments package installed, e.g.

yum install python-pygments

The gem is only a wrapper for it.

  • python-pygments is installed and up to date (I even tried python3-pygments)
    – frans
    Apr 2, 2015 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.