0

I have a virtual host running 4 VMs, one of which is the Domain Controller. All of them are joined to the domain, as well as another virtual host, and 1 workstation. I went to add another domain controller on the new virtual host, but when trying to join the domain I get 2 errors, depending on what I put in the "Domain" field when joining.

If I put "mydomain.local" in the Domain field I get:

The following error occurred attempting to join the domain "mydomain.local": The network path was not found.

If I put just "mydomain" in the Domain field I get:

An Active Directory Domain Controller (AD DC) for the domain "mydomain" could not be contacted. Ensure that the domain name is typed correctly. If the name is correct, click Details for troubleshooting information.

The new server is pointing at the PDC for DNS, and the PDC is pointing at itself. I have tried formatting this server, which didn't work, then I also tried joining a workstation to the domain and got the same result.

I got this error after restarting the PDC:

Name resolution for the name 10.in-addr.arpa timed out after none of the configured DNS servers responded.

But I assume thats just because it is the only DNS server. Any ideas on what could be causing this?

  • Can you PING the domain controller/DNS server(s) from the workstations or other servers on the network? If not, there might be a firewall issue on the DC/DNS server that is not allowing other machines to see it. For the newer machines are they set up on the same network? – Mark Apr 3 '15 at 20:37
  • 1
    Ping isn't an AD or DNS diagnostic tool. Whether ping fails or succeeds, it tells you nothing about the actual problem. Can you query for the DC successfully using nslookup on the client? Can you query for the domain SRV records successfully using nslookup from the client? Have you run the AD and DNS BPA's on the server? – joeqwerty Apr 3 '15 at 21:16
  • nslookup returns UnKnown for default server, but it does return the ip address of the PDC. BPA for DNS returns a warning for DNS server should have scavenging enabled. – Matt Fogleman Apr 6 '15 at 12:35
  • BPA for DNS returns a warning for DNS server should have scavenging enabled. And 2 errors for setting a secondary DNS, and making one of the DNS servers the loopback address. Below is BPA for ADDS i.imgur.com/pMFI9kl.png – Matt Fogleman Apr 6 '15 at 12:44
  • Turned the firewall off on the PDC and it worked, I had also set the DNS loopback for the secondary, but it was probably the firewall. I assume it's not best practice to have the firewall off on a server, seems odd that it started blocking requests out of no where. Is there something I could have done to cause this? Best thing to do now would be turn the firewall back on and add the exceptions correct? – Matt Fogleman Apr 6 '15 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.