1

I am trying to install mysql server 5.5 (or any 5.x versions) on Redhat 5.5 and am having some trouble.

I can install the other mysql components but when I try to install mysql-server (or mysql51-mysql-server/mysq55-mysql-server) I get the following error after Running Transaction:

Running Transaction
Error in PREIN scriptlet in rpm package mysql55-mysql-server-5.5.32-3.el5.x86_64
error: %pre(mysql55-mysql-server-5.5.32-3.el5.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping mysql55-mysql-server-5.5.32-3.el5

Failed:
  mysql55-mysql-server.x86_64 0:5.5.32-3.el5

I have tried to download the rpm packages directly but get the same error.

I can install with RPM using:

rpm -ivh MySQL-server-5.5.42-1.rhel5.x86_64.rpm --noscripts

I know that is not recommended with good reason since it installs but does not function. I get other errors (can't create PID files). Anyway I won't get into that here.

Note: I don't have root, but I can sudo most commands but other commands like rpm -ql is not allowed. I am also not allowed to add any additional Repos. I only have RHEL5.10_64 available.

  • The "(2)" string in the error message shows relatively clearly, that there is some "file not found" problem. I suggest to strace it. – user259412 Apr 4 '15 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.