1

When RHEL 7.0 and Centos 7.0 was first released I was able to install OS on B120i raid controller by following official RHEL 7.0 and HP docs:

  • Download the B120i controller driver from HP. Files you may need:

    hpvsa-1.2.12-110.rhel7u0.x86_64.dd or hpvsa-1.2.10-120.rhel7u0.x86_64.dd.gz (or latest versions).

  • Create USB drive disk (this will be loaded later during OS install). This can be created with the dd command. If possible name the flash drive as "OEMDRV". Sample dd commmand below.

    dd if=/dev/zero of=/dev/sdc bs=4K
    dd if=hpvsa-1.2.12-110.rhel7u0.x86_64.dd of=/dev/sdc bs=4K && sync
    
  • During first boot, press "Tab" and pass extra following parameters:

    modprobe.blacklist=ahci inst.dd
    

Since 7.1 release this no longer works

I even tried disable signature checking of modules but no luck.

Any ideas?

lsmod doesn't show this module to be loaded, but modinfo provides info as per usual.

/var/log/dmesq shows multiple lines about unable to verify hpvsa and etc.

I tried to force load manually and it seems it loaded, but I couldn't see my logical drives.

  • Was googling previously and found following article - seems to be related to my question, but no answer: centos.org/forums/viewtopic.php?f=49&t=51892 – efusiweb Apr 5 '15 at 11:59
  • It's probably just not supported yet. Why would you expect 7.1 compatibility to be ready now? – ewwhite Apr 5 '15 at 15:11
3

Indeed, it was needed to use the proper driver version, so no mpdprobe is required during install. I used hpvsa-1.2.14-100.rhel7u1.x86_64.dd.gz with Centos 7.0 1503-01.

I Googled hpvsa-1.2.14-100.rhel7u1.x86_64.dd.gz and downloaded from

I created the disk image with the drivers on a mac using:

sudo dd if=hpvsa-1.2.14-100.rhel7u1.x86_64.dd of=/dev/disk2  

or whatever device is used by the usb stick. Be sure is unmounted.

With this configuration, I managed to install the b120i raid 1 driver and booted as normal.

Do the following during installation:

  • Press tab during the initial screen
  • Append the following boot commands:

    modprobe.blacklist=ahci inst.dd

The first one avoids loading any sata drivers and the second one asks for additional drivers so no duplicated had disks.

I didn't remove the usb stick because it was hard to extract the memory stick without generating problems.

Anyway, it worked. Cheers.

1

Solution is simple - answering to my own question :) During boot - do ctrl+alt+f2, in command line: modprobe -f hpvsa, go back to gui installer, re-scan disks - you should see your logical volumes now. Problem that hpvsa drivers from HP incorrectly compiled. modprobe -f command forces to load without checking versions.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.