1

I'm runninng Opennms in a Docker.io container: https://registry.hub.docker.com/u/study/opennms/

$ docker run --name some-postgres -e LC_ALL=C.UTF-8 -d postgres

and

$ docker run --name some-opennms --link some-postgres:postgres -p 8980:8980 -d 'study/opennms'

Works like a charm. user/pwd: admin/admin as default login.

I've added a custom http detector through Home > Admin > Provisioning Requisitions > Edit Foreign Source Definition. The detector basically checks the 8111 for a HTTP 200 response, named it teamcity as it's meant to detect Teamcity running.

Added a node through Home > Admin > Add Interface which appears on the Home > Search > Node List screen.

Now the problem I have is: in the availability window the custom service shows as "Not monitored". Looked around on the interwebs, found this: http://www.opennms.org/wiki/FAQ-Configuration#Q:_Why_are_some_services_listed_as_Not_Monitored.3F

Logged into the container:

$ docker exec -it opennms bash

Checked the config file: /etc/opennms/poller-configuration.xml. File is just the default configuration, doesn't show any custom added servcices. So I search the filesystem

$ cat /etc/opennms/*.xml | grep *teamcity*

It finds the detector /etc/opennms/default-foreign-source.xml. But that file doesn't contain the service definition which includes the option to switch the service detection on, it just contains the detectors.

How do I get the availability of the service to show as "monitored"? Can I configure the poller to check the availability of a service from the admin UI?

1

To enable polling (and thus monitor the service state) you actually have to edit the poller-configuration.xml and add an entry for the service you want to poll. I was pretty amazed to find that Opennms does not supply a UI for this rather crucial use case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.