1

The way my network works, is my DHCP server (pfSense) is on another server at 192.168.1.1. My Mac server is at 192.168.1.2, and my TFTP server (latest version of Debian) is at 192.168.1.3.

I've configured DHCP options 66 and 67 on the DHCP server, and I have installed the tftpd-hpa package on the Debian server. I'm able to boot a PC from the PXE server when I use a USB stick to transfer the pxelinux files to the /srv/tftp directory, so I know TFTP is working properly.

The issue is Samba. Samba came pre-installed on Debian, and I've also tried removing and re-installing it using aptitude. I want to serve the /srv/tftp directory using Samba and authenticate to the Samba share using a non-root account I've made using "adduser". I've added the following to my /etc/samba/smb.conf file:

[tftp]
comment   = tftp directory  
writeable = yes
locking   = no
path      = /srv/tftp

I then added my user account to Samba's password list using smbpasswd -a myusername
I can then see the share on my iMac, and on a Windows PC. When I try to mount the drive on either, the Windows PC (Win7) states that the share isn't accessible, and my Mac displays this: error dialog box
It's able to see the share if I access the drive, as it appears alongside the share for my home folder, yet the tftp share isn't mountable, and the home folder is.

  • try "public=yes" for the tftp section and see if that fixes it. – Matt Apr 8 '15 at 1:48
  • Do the directories /srv and /srv/tftp have read and execute permissions(755) set? – artifex Apr 8 '15 at 1:51
  • Post the output of smbclient -L 192.168.1.3 -N from another Linux box. Do you see the share in the output. – Daniel t. Apr 8 '15 at 2:05
  • Hi, yes, they're actually on 777, it's a low-security environment. I'll post the output in a moment. – Thomas Jones Apr 8 '15 at 2:51
  • Yes, I see the share listed. – Thomas Jones Apr 8 '15 at 2:51
0

Add your windows workgroup, security and share mode to the global section of smb.conf

[global]
   ...
   workgroup = MY_WG
   security = share
   share modes = yes

[tftp]
   comment = tftp directory
   read only = no
   create mode = 0750
   locking = no
   path = /srv/tftp
   guest ok = no

After adding yourself as a Samba user by

# smbpasswd -a myusername

you must re-start the daemon by

# /etc/init.d/samba restart

Please note that the /srv/tftp mount point must be given the 777 rights, so that everyone can write to it.

chmod 777 /srv/tftp

you can use a more restrictive mask if needed (please edit the corresponding "create mode" variable under the [tftp] section).

  • Hi Pat, unfortunately that hasn't solved the problem. I have since wiped Debian and done a clean install. I have followed the directions here (wiki.debian.org/SambaServerSimple) for Samba setup (instead of the way I usually do it, which doesn't differ much from the Debian documentation, and yet it still does not function. I'm just not able to mount the tftp share, but the thing that bugs me is that I'm able to mount my default home directory share with no problems/mirroring permissions to /srv/tftp. It's truly a baffling problem. – Thomas Jones Apr 14 '15 at 1:13
  • In order to minimize the guesswork I'd run wireshark on let say the Windows client while trying to map the share and try to see on the traffic capture why the map "really" fails. This way you can confirm if this is a problem of SMB protocol version, a permission issue, or whatever. – Pat Apr 14 '15 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.