1

I'm working with a Spacewalk deployment and have gotten around to the point where I'm looking to boot via pxe using a kickstart file. I've mounted an iso onto the disk using mount -o loop and have created a distro pointing at the mounted iso within Spacewalk. Kickstart is subscribed to two channels; a base channel with all CentOS 7 files in, and an updates channel with the updates repo synced.

When booting, it gets through the initial dhcp and finding the required files, but then as it reaches the 'starting package installation process' part on anaconda - post most of the base OS install - it then throws the following error:

Image of the error being presented within Anaconda

There's not much support on this - and any support I can find is on the official Redhat forum and requires a subscription to be viewed.

Now, I'm assuming it's to do with the iso file seeing as that's used to set the OS up. What I'm looking for is a iso that meets the version requirements stated in the error (if it is indeed the issue). I've tried a few resolutions to no avail, and I'm now a bit lost. Kind of new to the concept of kernels and such, so any advice is appreciated.

Thanks.

1

Resolved this by using a more up to date iso (with I assume a firmware version that matched the requirements). It wasn't good enough just to mount the iso on the same mount point as the old (which I tried); I had to instead create a new distro within Spacewalk pointing at a new mount point (where the new iso was mounted), and then update the kickstart I was using to use the new distro.

Thanks for those who were considering answering.

  • You should mark this answered. Thanks for putting the answer up. It will no doubt help someone in the future. – Xalorous Aug 30 '16 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.