0

I am running the Tomcat manager application via a Debian package (tomcat8-admin), which deploys the webapp from /usr/share/tomcat8-admin/manager. We ran into a problem hitting the maximum upload size (configured as the multipart-config element in the HTMLManager servlet block). This is easy to fix if you're willing to edit Debian-packaged files, but this is incorrect: files in /usr/share are owned exclusively by dpkg. Is there a way to override this element from somewhere in tomcat's conf directory (which is symlinked to /etc/tomcat8 in Debian)?

Searching for this problem on the web only results in suggestions about editing web.xml directly (eg http://www.giantgeek.com/blog/?p=1000) or about different programming approaches using context parameters (if I understand correctly; I'm not especially familiar with the jargon).

If it's not possible to override this at the moment, then I'd be interested in suggestions about the best place to file a bug: is it that web.xml shouldn't contain site-specific options, as I have read - in which case does the fault lie with Tomcat? Or is the Debian packaging faulty, and should web.xml be made into a config file and symlinked from /etc?

Of course I could maintain a local version of the Debian package with this overriden, but for such an apparently-obvious piece of configuration that seems wrong too.

-1

You can install tomcat without dpkg. Also which folder you want. Some googling can help. After that make multipart conf in web.xml.

  • Downvoting because this doesn't answer the question or contain any useful information. Sorry. – Andrew Schulman Apr 11 '15 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.