0

I'm trying to configure Zenoss 4.2.X to use an SSL-enabled URL in the login form.

I have nginx as an SSL reverse-proxy sending requests to Zenoss listening on port 8080. This works.

However, the login form uses "http://10.1.2.3:8080/zport/acl_users/cookieAuthHelper/login" as the POST action. This is a non-starter!

I need to configure Zenoss to use a different URL in the login form's POST action field. I've searched the internet and Zenoss docs to no avail. The closest answers I've found do not show this problem.

I've tried the following:

  • Set <cgi-environment> in ZENHOME/etc/zope.conf as follows:

    <cgi-environment>
        HTTPS ON
        HTTPS_PORT 443
    </cgi-environment>
    

    But this causes a 302 redirect to https://10.1.2.3/.... which is not correct. SSL is only on the nginx proxy.

  • I tried setting server_name to the fqdn in nginx, but the URL in the login form is still the http://10.1.2.3/... value

Basically I'm just looking for a way for the backend SSL reverse-proxy to stay intact, but the UI, only, get rewrites to change the "app URL" to be the https:// version.

In many LAMP apps, there's a configuration directive to set the app URL. (e.g. Moodle, Drupal, Worpress). Does Zope have something similar?

  • Why the down vote? SO is super frustrating anymore – JDS Apr 9 '15 at 11:35
0

Everything what do you need to setup - it's your case nginx as reverse proxy for zope: http://wiki.zenoss.org/Newsletter:5/Encrypt_All_the_Bits

  • I have no idea why this got downvoted -- I didn't do it. I finally found a solution, and it is this link that you posted. I really wish people would state why they down vote. FWIW I upvoted you back to zero. – JDS Apr 9 '15 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.