1

I have an issue here, I am new on this, I've been watching some tutorials and I see that everything is OK in my configuration but I can not access to my page with the subdomains.

Here is the report of my SSL domain from SSL LABS

and here I have the config file

this is the one for the domain

#////////MOBILE//////    
server {
  listen 80;
  server_name just4bettors.mobi;
  return 301 https://$host$request_uri;
}
server {
  listen 443 ssl;
  server_name just4bettors.mobi;
  include ssl.conf;
  root   /home/c0pt/capilleira/capilleiraclickandgamblemobile/www;
  location / {
    index  index.html index.htm;
  }
  include protect_system_files.conf;
  include expires.conf;
}

and then in a separate block I have 2 subdomains

#//////BACK END//////
server {
  listen 80;
  server_name backend.just4bettors.mobi;
  return 301 https://$host$request_uri;
}
server {
  listen 443 ssl;
  server_name backend.just4bettors.mobi;
  include ssl.conf;
  location / {
    include security.conf;
    include backend_proxy_pass.conf;
  }
  include protect_system_files.conf;
}


#////////DESKTOP//////
server {
  listen 80;
  server_name desktop.just4bettors.mobi;
  return 301 https://$host$request_uri;
}
server {
  listen 443 ssl;
  server_name desktop.just4bettors.mobi;
  include ssl.conf;
  root   /home/c0pt/capilleira/capilleiraclickandgambleweb/dist;
  location / {
    index  index.html index.htm;
  }
  include protect_system_files.conf;
  include expires.conf;
}

as you see I have the backend in a subdomain. At this moment I can see the domain just4bettors.mobi, but once I attempt to enter, I receive an error OPTIONS http://localhost:1337/auth/login net::ERR_CONNECTION_REFUSED, Look that I have the domain aiming to the backend subdomain, and if I attempt to enter to the desktop.just4bettors.mobi subdomain I get this in the browser This webpage is not available and this in the browser console GET https://desktop.just4bettors.mobi/ net::ERR_NAME_NOT_RESOLVED

so, what am I missing here ?

1
  • 1
    Good job on your A+.
    – Ryan Ries
    Apr 9 '15 at 1:35
4

The desktop subdomain doesnt seem to be setup in DNS. Nor is backend.

You need to set A records for those subdomains in your DNS, which appears to be ultradns.net

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.