0

wondering ipv6 static route default route nothing working, only can ping the directly connected interface, but sh run command gave the static routes which I created to other networks, but on the sh run output I saw the autoconfig static route which I created to obtain global unicast addresses and on the next line I saw the static route which i created to reach remote network, Any ideas? I cant see any successful ping to remote network

I give more information 3 routers in a row, routerA, routerB, routerC, connected via fastethernet. middle router B had it's ipv6 address configured manually and other two routes receive global unicast address through ipv6 address autoconfig command

here is the "Sh run" output of router A

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption 
!

hostname Router
!

! 
!

!
!

ipv6 unicast-routing
!

!
!

!
!

!
!

!
! 

!
spanning-tree mode pvst
!

!
!

!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address autoconfig
ipv6 enable
!

interface FastEthernet0/1
no ip address 
duplex auto
speed auto
shutdown
!

interface Vlan1
no ip address
shutdown
!

ip classless
!

ipv6 route 2001:DB6:3C4D:1::/64 FastEthernet0/0 FE80::200:CFF:FE4A:AC01
ipv6 route 2001:DB6:3C4D:2::/64 FastEthernet0/0

THE SH RUN OUTPUT OF ROUTER C

Building configuration...

Current configuration : 660 bytes
!

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!

hostname Router
!

!
!

!
!

ipv6 unicast-routing
!  

!
!

!
!

!
!

!
!

!
spanning-tree mode pvst
!

!
!

!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address autoconfig
ipv6 enable
!

interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown  
!

interface Vlan1
no ip address
shutdown
!

ip classless
!

ipv6 route 2001:DB6:3C4D:2::/64 FastEthernet0/0 FE80::200:CFF:FE4A:AC02
ipv6 route 2001:DB6:3C4D:1::/64 FastEthernet0/0
!

!
!

!
!

!
line con 0
!

line aux 0
!

line vty 0 4
login
!

!
!

end

Router A routing table

Router#sh ipv6 route 
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP  
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary   
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB6:3C4D:1::/64 [0/0]
via ::, FastEthernet0/0
L   2001:DB6:3C4D:1:260:5CFF:FEA8:3A01/128 [0/0]
via ::, FastEthernet0/0
S 2001:DB6:3C4D:2::/64 [1/0]
via ::, FastEthernet0/0
L FF00::/8 [0/0] 
via ::, Null0
Router#

router C routing table

Router#sh ipv6 route 
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2   
D - EIGRP, EX - EIGRP external
S 2001:DB6:3C4D:1::/64 [1/0] 
via ::, FastEthernet0/0
C 2001:DB6:3C4D:2::/64 [0/0]
via ::, FastEthernet0/0
L 2001:DB6:3C4D:2:290:CFF:FE49:7601/128 [0/0]
via ::, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0

there static route is defined and why it's not pinging!

middle router B configuration

Router#sh run
Building configuration..

Current configuration : 590 bytes
!

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption 
!

hostname Router
!

!
!

!
!

ipv6 unicast-routing
!

!
!

!
!

!
!

!
!

!
spanning-tree mode pvst
!

!
!

!
interface FastEthernet0/0
no  ip address
duplex auto
speed auto
ipv6 address 2001:DB6:3C4D:1::1/64  
ipv6 enable
!   

interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2001:DB6:3C4D:2::1/64
ipv6 enable   
! 

interface Vlan1
no ip address
shutdown
!

ip classless
!

!
!

!
!

!
!

line con 0
!  

line aux 0
!

line vty 0 4
login
!

!
!

end

why router A and C are not pinging?

thanks for the answear , I disable one static route for a directly connected interface ,still it's pinging it's directly connected neighbor only, when I tried from router C to router b ,not even pinging the remote exit interface of router B to router A, here I provide the sh run output of router C after configuration change

Building configuration...

Current configuration : 588 bytes
! 
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
! 
ipv6 unicast-routing 
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address autoconfig
ipv6 enable
!
interface FastEthernet0/1
 no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
 no ip address
shutdown  
!
ip classless
!
ipv6 route 2001:DB6:3C4D:1::/64 FastEthernet0/0
!
!

routing table on C

Router#sh ipv6 route 
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
   U - Per-user Static route, M - MIPv6
   I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
   O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
   ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
   D - EIGRP, EX - EIGRP external
S   2001:DB6:3C4D:1::/64 [1/0]
 via ::, FastEthernet0/0
C   2001:DB6:3C4D:2::/64 [0/0]
 via ::, FastEthernet0/0
L   2001:DB6:3C4D:2:290:CFF:FE49:7601/128 [0/0]
 via ::, FastEthernet0/0
L   FF00::/8 [0/0]
 via ::, Null0
  • This question looks platform specific. Could you please tag it with the name of the routing platform you are using. – kasperd Apr 11 '15 at 13:25
0

If I interpret the configuration correctly, you tell neither router A nor router C that they should use router B to reach the respective other network (via 2001:DB6:3C4D:1::1, resp. via 2001:DB6:3C4D:2::1 instead of via ::). In fact, you configured A and C with both networks 2001:DB6:3C4D:1::/64 and 2001:DB6:3C4D:2::/64 on their respective local link.

  • thank u, changed the configuration still not pinging, see the bottom on answearfor editted answear – Brathaban Balachandran Apr 12 '15 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.