0

I have Percona XtraDB Cluster 5.6 installed on my Ubuntu server. Recently, when i tried to update my system using apt i see some new version of percona, but with an older version.

The following packages will be upgraded:
  percona-xtrabackup percona-xtradb-cluster-client-5.5 percona-xtradb-cluster-common-5.5 percona-xtradb-cluster-galera-2.x percona-xtradb-cluster-server-5.5

So i want to keep my 5.6 version and still update all the other packages. I try using some lines in the /etc/apt/preferences.d:

Package: *
Pin: release o=Percona Development Team
Pin-Priority: 1001

Package: percona-xtradb-cluster-*
Pin: version 5.6*
Pin-Priority: 550

But it doesn't work. I found many solution to not upgrade from 5.5 to 5.6 but nothing concerning my problem.

2
  • Which versions of the percona packages have you got installed? Do you have both the 5.5 and 5.6 versions? If so apt is doing the right thing and the fix would be to remove the 5.5 version leaving just 5.6. Apr 14, 2015 at 14:54
  • I'm so stupid, you're totally right. I need to take some rest ...
    – Spin0us
    Apr 14, 2015 at 15:20

1 Answer 1

0

[turning my guess into an answer]

Sounds like you've got the 5.5 and 5.6 packages installed.

If so apt is doing the right thing. Fix is to remove the 5.5 version leaving just 5.6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.