3

I am running a vmware environment (Version 4 unfortunately) which requires me to use a bios rom file in order to run server 2012. I upload it to the root folder of the VM after creation, before boot and change some config lines.

bios440.filename = bios.440.rom
mce.enable = TRUE
cpuid.hypervisor.v0 = FALSE
vmGenCounter.enable = FALSE 

Configuration Parameters and ROM from here

That works perfectly until I clone the VM or try and deploy a template. The file is not copied.

Is there any way to tell vmware that the file needs to be copied with the VM when cloning or deploying from template?

bios440.filename =[ESX-ISO (SAN1)] ROMs/bios.440.rom

Where the name of the datastore is ESX-ISO (SAN1)

4
  • I'd suggest that making a long-term shim for this is far more effort than using a current and supported version of VMware. There's no excuse to still be on version 4 of vSphere in 2015. For your immediate situation, add a step to the process to make sure this boot file is present. – ewwhite Apr 14 '15 at 18:53
  • It's not an arrogant stance; I'd say that it's fairly accepted professional sysadmin practice to stay within a vendor's compatibility list. You say yoou have good reasons to stay on 4.0, but you also have good reasons to upgrade to 5.x - specifically, running Win2012. – mfinni Apr 14 '15 at 19:18
  • Have you tried just going into the datastore and copying/pasting the VM you want to copy and adding the resulting clone to the inventory? – Nathan C Apr 14 '15 at 19:43
  • That would work but then I do not get the deployment options from templates and its just as easy to copy the ROM. Thanks though. – ZZ9 Apr 14 '15 at 20:09
2

I found a solution... put the bios.440.rom in a "common" location and then give the full path to the rom in the VMX file

"/vmfs/volumes/mydatastore/bios.440.rom"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.