While attempting to change the MySQL server timezone to CDT to match the Centos sytem time, something has messed up. I edited the my.conf in /etc/ in vim logged in to SSH as root, and saved it. On service mysql restart, I got the following error:

root@server [~]# service mysql restart
 ERROR! MySQL server PID file could not be found!
Starting MySQL. ERROR! The server quit without updating PID file (/var/lib/mysql/server.find-minecraft-servers.com.pid).
root@server [~]# 

This keeps going round in circles. I've tried locating that pid file - it's not apparant. I've tried service mysql status, it mentions a lock file in /var/lock/subsys/mysql - I delete this, nothing changes. Please help me out.

The contents of my.conf is:


(I reset it after the timezone change messed it up.)


If mysqld is running (check your process table), you should probably stop it via a kill command (dont use kill -9 as that will do an un-graceful stop of the service).

When mysqld is no longer present in the process table, start the service normally.

  • Note that this may result in some database corruption, but generally MySQL should be able to recover just fine. Apr 14 '15 at 23:23
  • Agreed, but you probably have no choice at this point if the lockfile is gone
    – Chad Smith
    Apr 14 '15 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.