0

In a server running for last 8 months we had been accessing this URL: https://dl.google.com/dl/cloudsdk/release/components-2.json through curl. A few days ago it stopped working suddenly and says

  1. That's an error. That's all we know.

enter image description here

But the most strange part it this is happening on this only machine only. All other machines are able to access it without a problem. This problem machine is able to access all other internet sites including google, gmail etc.

All machines are running CentOS 6.4.


These are two curl output when get the json file

This is the machine which fails:

# curl -v https://dl.google.com/dl/cloudsdk/release/components-2.json
* About to connect() to dl.google.com port 443 (#0)
*   Trying 4.59.40.88... connected
* Connected to dl.google.com (4.59.40.88) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_RSA_WITH_RC4_128_SHA
* Server certificate:
*   subject: CN=*.google.com,O=Google Inc,L=Mountain View,ST=California,C=US
*   start date: Mar 25 14:48:48 2015 GMT
*   expire date: Jun 23 00:00:00 2015 GMT
*   common name: *.google.com
*   issuer: CN=Google Internet Authority G2,O=Google Inc,C=US
> GET /dl/cloudsdk/release/components-2.json HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.16.2.3 Basic ECC zlib/1.2.3 libidn/1.18 libssh2/1.4.2
> Host: dl.google.com
> Accept: */*
> 
< HTTP/1.1 404 Not Found
< Content-Length: 1364
< Content-Type: text/html; charset=utf-8
< Server: downloads
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-Xss-Protection: 1; mode=block
< Date: Wed, 15 Apr 2015 09:32:31 GMT

This is the machine which succeeds:

# curl -v https://dl.google.com/dl/cloudsdk/release/components-2.json
* About to connect() to dl.google.com port 443 (#0)
*   Trying 74.125.141.136... connected
* Connected to dl.google.com (74.125.141.136) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using SSL_RSA_WITH_RC4_128_SHA
* Server certificate:
*   subject: CN=*.google.com,O=Google Inc,L=Mountain View,ST=California,C=US
*   start date: Mar 25 15:57:18 2015 GMT
*   expire date: Jun 23 00:00:00 2015 GMT
*   common name: *.google.com
*   issuer: CN=Google Internet Authority G2,O=Google Inc,C=US
> GET /dl/cloudsdk/release/components-2.json HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.13.6.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
> Host: dl.google.com
> Accept: */*
> 
< HTTP/1.1 200 OK
< Accept-Ranges: bytes
< Content-Length: 48061
< Content-Type: application/json
< Etag: "526ef"
< Expires: Thu, 16 Apr 2015 02:32:38 PDT
< Last-Modified: Thu, 09 Apr 2015 16:52:00 GMT
< Server: downloads
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-Xss-Protection: 1; mode=block
< Date: Wed, 15 Apr 2015 09:32:38 GMT
< Alternate-Protocol: 443:quic,p=0.5
  • It is working from all other machines in the same data center. Each machine has a different public IP address. I tried from other machines in different countries and it is working. The problem machine is in the US. – Zulqarnain Habib Apr 15 '15 at 3:55
  • 1
    OK, maybe it is not national censorship then. The US doesn't censor Google....most of the time :) – Michael Hampton Apr 15 '15 at 3:57
  • 4
    Any chances that Google is blocking it? – Zulqarnain Habib Apr 15 '15 at 4:01
  • Also you might want to try this alternative URL dl-ssl.google.com/dl/cloudsdk/release/components-2.json. You might be hitting a broken mirror – Dobromir Velev Apr 15 '15 at 9:03
  • 1
    I see a difference in User agent line in the server which fails and the server which succeeds. I am posting in reply as this comment box doesn't allow that much characters. – Zulqarnain Habib Apr 15 '15 at 9:36
1

The issue was resolved when we changed the Public IP from a different IP block. Looks like Google wasn't liking the IP anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.