1

We have following server details and we need to upgrade apache 2.4.6 to apache 2.4.12

OS: CentOS 6
Apache : 2.4.6
PHP : 5.5

I know how to install 2.4.12 from scratch but i just want to upgrade current apache to 2.4.12 because i don't want to loss php settings and other settings of current apache.

marked as duplicate by Jenny D, Andrew Schulman, Sven Apr 15 '15 at 8:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why do you think you need to do this? – Michael Hampton Apr 15 '15 at 6:05
  • @MichaelHampton We have gone through PCI Scan and They have suggested to use apache 2.4.10 or 2.4.12 to prevent Multiple Vulnerabilities – GBD Apr 15 '15 at 6:08
  • 2
    No, you don't need to do that. You need to show them that you have updated to patch those vulnerabilities. These updates are provided by CentOS already, though the version number remains 2.4.6. See, among others, serverfault.com/a/438312/126632 – Michael Hampton Apr 15 '15 at 6:10
  • @MichaelHampton Is there any way we can send them such report that centos has already implemented such patches but version number is same ? – GBD Apr 15 '15 at 6:14
  • rpm -q --changelog httpd | less will show the CVE's that have been patched. You can then match them up to the CVE's mentioned in the PCI audit. – Michael Hampton Apr 15 '15 at 6:16
0

If you simply upgrade using rpm -U, the binaries will be upgraded, but the configuration files will remain the same. See https://stackoverflow.com/questions/14511334/rpm-upgrade-handling-of-config-files

Not the answer you're looking for? Browse other questions tagged or ask your own question.