1

We have trouble with the SearchIndexer on Windows 2012 R2. Microsoft suggests do uninstall the feature and reinstall it.

Where can I do that in Windows Server 2012? Can't find the feature in the feature list.

3

Open Server Manager, click on Add roles and features click next until you get to Features and then uncheck Windows Search Service and complete the wizard.

You might be best of sharing the issue you are having as well, is it a performance issue due to this service?

  • Also if you are not using this service or don't want to index you can disable the service instead WSearch. – 0x0000001E Apr 16 '15 at 15:32
  • It's de grayed and can't be unchecked (tested with started and stopped service) – marsh-wiggle Apr 16 '15 at 15:36
  • Are you a local admin? You can also try the PowerShell command, but make sure you are running the shell as an administrator Uninstall-WindowsFeature Search-Service. This also requires a restart. – 0x0000001E Apr 16 '15 at 15:48
-1

I simply stopped the "Windows Search" service on the server (Server 2012 Standard) and it instantly fixed this issue. I have now disabled it.

enter image description here

  • 1
    The question was how to fix, not how to disable it. And please stop shouting (writing all caps). – Sven Aug 30 '16 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.