4

Created a new WDS (VM) server, installed WDS role, added boot/install image from Win7 Pro SP1 x64 volume license disc. Client I am booting is 64-bit but then I get this:

Downloaded WDSNBP from 192.168.1.10 WDS.contoso.com

Press F12 for network service boot

Windows Deployement Services: PXE Boot Aborted
PXE-M0F: Exiting PXE ROM
  • Client PC is Optiplex 3020
  • Intel Core i5-4590
  • Realtek RTL8151GD (per Dell; Hardware ID: PCI\VEN_10EC&DEV_8168)
3

---EDIT: Default WDS settings (Properties, Boot) dictate you have to hit F12 (quickly) to continue booting, otherwise you will get PXE Boot Aborted. I am sure this is designed so that a boot order with NIC/PXE 1st will still boot to local devices without user intervention

WDS log (Source Deployment-Services-Diagnostics, Event ID 57347) advised: The PXE server processed a request from a client of architecture x86. However there were no boot images installed for this architecture

It seems either my NIC/PXE-code or BIOS is providing an invalid response to the architecture. Maybe its based on the processor on the NIC, I am not an engineer so I can't say for certain. However per microsoft:

Each computer that will be booting from the network should have DHCP option 93 to indicate the client’s architecture. This enables a PXE server to know (at boot time) the exact architecture of the client from the first network boot packet. On many x64-based computers, the architecture value either is not set or is not set to the expected value. Generally, this means that the architecture is specified as x86-based but the computer is x64-based

This article refers to a System Center component, however if you search for x86 (the 6th iteration) it advises you should have a x86 and x64 boot image. I guess you can FORCE it to boot a x64 (this may cause you trouble in the future) by opening WDS, right-clicking server, Properties, Boot tab

0

A while ago we had similar issues 'Windows Deployement Services: PXE Boot Aborted'. In our case the problem was way simpler - some of our new laptops had that fancy 'F Lock key' functionality i.e. you need to press Fn + F12 to activate F12.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.