1

I have the weirdest problem I was hoping you could help me with. I've got a dedicated Server 2012R2 server with an Intel 82580 network adapter. It runs a couple of VMs in Hyper-V that are attached to an Internal virtual switch. This switch is then NATted to various IP addresses on the real interface of the server.

I've currently got two guests running, an Ubuntu guest and a Server 2008R2 guest. Both get really good download speed (90Mbps, about what the dedicated server gets) but the upload speed is really bad. The dedicated server has an upload speed of about 60Mbps, the 2008R2 VM gets about 5Mbit and the Linux VM gets a speed too low to measure, the test just reads 0.00Mbit.

Does anyone know what the issue could be here? I've tried disabling VMQ, disabling IPv4 checksum offloading and disabling IPsec task offloading, none of which made any difference what-so-ever.

  • what's the storage? I'd guess writing to the virtual disk is the bottleneck and not the actual bandwidth / network. – user16081-JoeT Apr 17 '15 at 2:31
1

I appear to have solved the issue by disabling large send offloading in the guest operating systems. Disabling it on the host didn't help but disabling it on the guests solved the issue.

  • Thanks for the tip. I had a similar problem, and disabling large send offload resolved it. – Thomas Levesque Jan 23 '16 at 15:48
  • Solved the issue for me as well inside a Virtual Machine using Veertu 1.2 running W10 on a Mac. – Peheje Feb 1 '17 at 16:12
  • Instead of disabling Large Send Offload in the VM, you can also disable it on the vEthernet interface that Hyper-V creates on the host OS (useful if you have multiple guests using the same virtual switch.) – Joe the Coder Oct 19 '18 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.