I have a Windows 2003 server x86, which I have manually installed .Net 3.5 SP1, but now, the Windows Update:

Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86

failed to install with error:

Error Code: 0x80070643
Try to install the update again, or request help from one of the following resources.

What to do?


Have you tried running the installation package outside of Windows Update? You find the package in %WINDIR%\SoftwareDistribution\Download\Install once you've tried to install it. Normally, this way you get better error messages

Updated: You may try this: Stop service Windows Updates from services.msc and delete or rename SoftwareDistribution folder afterwards. Start Windows Updates again and it should recreate the folder structure (at least when new updates arrive)

  • There is an old package in there (KB958481). I'm running in right now, but it get stuck. Maybe this is the real problem... – Eduardo Molteni Sep 24 '09 at 14:24
  • Maybe it's just an old installation package...Try again or see my updated answer to "clean" this downloaded stuff – Scoregraphic Sep 24 '09 at 15:37
  • Embarrassing: There problem was not enough disk space on the system disk. – Eduardo Molteni Sep 24 '09 at 15:39
  • I had this one before with SP3 for SQL Server ;) – Scoregraphic Sep 24 '09 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.