0

I can not connect a computer to Server 2012 R2. the error message I receive is

Note: This information is intended for a network administrator. If you are not your network's administrator, notify the administrator that you received this information, which has been recorded in the file C:\WINDOWS\debug\dcdiag.txt. The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "sheptock.local":

The error was: "DNS name does not exist." (error code 0x0000232B RCODE_NAME_ERROR) The query was for the SRV record for _ldap._tcp.dc._msdcs.sheptock.local

Common causes of this error include the following:

The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses: 75.75.76.76

75.75.75.75

One or more of the following zones do not include delegation to its child zone: sheptock.local

local

. (the root zone) From the computer i can not ping or nslookup the server. On the server I am able to ping and do an nslookup. I also have done a DCdiag and that passes all the tests. I have also initiated ipconfig /registerdns. From the server if I run nslookup q=srv to _ldap._tcp.dc._msdcs.sheptock.local that also connects fine. the server is on a comcast Residential Cisco router. Please Help!

I followed the GUI to set up The domain which prompted me to promote the machine. Added the computer I was trying to connect to AD under computer. And added the user I made for the computer under users in AD.

closed as off-topic by Mathias R. Jessen, Katherine Villyard, 84104, Hyppy, Jim B Apr 22 '15 at 22:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Mathias R. Jessen, Katherine Villyard, 84104, Hyppy, Jim B
If this question can be reworded to fit the rules in the help center, please edit the question.

  • There is not enough information about your infrastructure. I would guess from your information that you are trying to join a domain over the internet? Or are your client and server on the same site? Your computer's DNS settings are definitely wrong in the latter case. (At least) all domain members should have their DNS server settings point to a/multiple DCs. In the first case: It won't work that way. – Oliver Rahner Apr 20 '15 at 7:08
  • The client and server are both on the same network. And I've set the Client DNS to point to the servers IP. It's my first time setting up a domain. I followed what technet had for their instructions – Tyler S Apr 20 '15 at 7:23
  • Sorry, Tyler. Those DNS servers are Comcast. – Katherine Villyard Apr 20 '15 at 18:09
2

I thought I recognized those DNS IP numbers.

You have DNS set to use Comcast's DNS, not the DNS that knows anything about sheptock.local. Change the workstation's DNS server to one that knows about steptock.local, including the DC for sheptock.local, and that should help.

You can probably do this in your aforementioned wireless router if you're using it for DHCP.

  • I've set the router to both bridged and not bridged and it still brings the same issue up... I've added dhcp on my end and it has changed the IP again. Long story short, it's comcasts equipment that's causing all of these DNS issues? If so what equipment would you recommend I use? – Tyler S Apr 20 '15 at 18:11
  • Rather than spend money, set a static IP on the workstation with static DNS. Try again. Set it back to DHCP after it succeeds. – Katherine Villyard Apr 20 '15 at 18:13
  • I've done that as well. They have a reserved IP address feature. Comcasts equipment from my understanding has certain features blocked. – Tyler S Apr 20 '15 at 18:14
  • 1
    I'm not talking about "reserved address." I'm talking about walking physically over to the workstation in question and manually setting the IP address and DNS server there. 4.bp.blogspot.com/-31kZGpwCDM0/VEIv5QXWgmI/AAAAAAAAOm4/… – Katherine Villyard Apr 20 '15 at 18:28
2

Configure the DNS server on your domain controller to use the public Comcast IP addresses as forwarders only, or allow your DC to use the root hints. All other devices on your network should point to the DNS server on your DC. Your DCs should then point to itself in the network properties.

Once this is all squared, the client that you're trying to add should be able to find your domain controller and join the domain.

-1

You cannot ping Windows 2012 Servers unless you enable it under the Windows Firewall by enabling the File and Printer sharing (Echo request – ICMPv4-In) rule (How to enable Ping in Windows Server 2012 | Thomas Balkeståhl's Blog).

You should also check the firewall rules about Active Directory Domain Services.

  • I have turned the firewall completely off trying to get this issue solved – Tyler S Apr 20 '15 at 14:23
  • Absolutely nothing in the question points in this direction... – Oliver Rahner Apr 21 '15 at 17:06
  • "From the computer i can not ping or nslookup the server". I was just explaining why he couldn't ping the server. And the problem could have been the firewall. – Dric Apr 22 '15 at 13:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.