2

I want to run imaps on a port other than 993.

I changed this in /etc/dovecot/conf.d/10-master.conf and beforehand, backed up the original copy as /etc/dovecot/conf.d/10-master.conf.bak. I did everything from

# service dovecot restart
# service dovecot stop
# service dovecot start
# doveadm reload
# doveadm restart

and even a complete server reboot.

Still, doveconf | grep 993 reports port = 993 in the output, while the port's been changed in the config file.

Note I'm also running roundcube and postfix, and connected my email account to the gmail app through SSL as well on port 993. I'm also not sure if I need to change any other configs to work with dovecot or not, other than my email settings on my phone for gmail app.

EDIT it turned out conf.d wasn't included....

  • What distro are you running? – squareborg Apr 25 '15 at 16:08
  • sometimes systemd scripts are broken (saslauthd on debian for example). Did you find the restarting messages in the logs ? if not you might want to try /etc/init.d/dovecot restart. – ychaouche May 9 '16 at 12:27
1

Are you running with SELINUX enabled? If so, selinux may block dovecot from binding to another port and, after that, it re-bind on the default port (993).

Try to temporarily disable selinux with setenforce 0 and to restart dovecot. Does that change anything?

  • This didn't change anything. SELinux isn't installed because I'm able to apt-get selinux. – cellsheet Apr 24 '15 at 22:25
  • Run setenforce 1 – shodanshok Apr 24 '15 at 22:27
  • @cellsheet if you are on a system that uses apt as it's package manager then SELinux will not be there by default. SELinux is a RHEL / CentOS thing. Apparmor on Ubuntu, but Apparmor does not manage ports like SELinux. – squareborg Apr 25 '15 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.