0

Below is a link to the instructions that allow you to connect to your AWS EC2 virtual private server, for an instance based on a Windows Server template during the AWS EC2 instance wizard. So far, I've chosen three different instance types that say "free tier eligible".

When I use the private key (*.pem file) to decrypt the password, and connect using Windows Remote Desktop, it won't connect to my newly created server (based on public IP address that EC2 assigned).

What could be the reason? I've opened up port 3389 for RDP (remote desktop) on each test. I've tried setting the inbound rule to 0.0.0.0/0 as well as "My IP", which defaulted to my external IP address. Neither worked.

https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/connecting_to_windows_instance.html

  • I find that even when server is created it for some reason takes about 15min before RDP starts working. When you perform a port scan on the IP address of server check whether you can can see 3389 open. – Ankh2054 Apr 27 '15 at 6:30
  • how do I do a port scan from my local machine for the virtual private server created on AWS EC2? – MacGyver Apr 27 '15 at 6:43
  • 1
    Get and install something called nmap OR Google online port scan and choose a site. Scan the public IP assigned by EC2. You can also try to telnet into server public IP on port 3389. – Ankh2054 Apr 27 '15 at 7:02
  • Which version of Windows are you using for the EC2 instance, and what OS are you attempting to connect from? – Chad Smith Apr 28 '15 at 20:16
  • Windows Server 2012 from Windows 7. See my answer for how I resolved the issue. – MacGyver Apr 28 '15 at 20:35
1

You don't go into detail on how you're logging in but if you're copying, and pasting the password using the mouse login often fails. Your answer describes a work-around but there is a hot-fix available for Windows 7 here: https://support.microsoft.com/en-us/kb/2547752

  • Good to know about this hot-fix. +1 – MacGyver Apr 29 '15 at 21:46
0

When I copied the password from the dialog on AWS, and pasted it into the Remote Desktop session on my local machine, it didn't work. I had to type it out.

0

In my case, I use the public key password to login Windows server, have you checked the key pair of security group and vm instance?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.