3

I have just taken delivery of the base spec Microserver gen8. I have installed a WD 1Tb drive in slot 1, and the BIOS/RAID controller finds it. However when I come to install Win server 2012 r2 it cannot find a drive and asks for a driver. I have downloaded all 3 drivers from the HP site onto a usb stick, which is recognised by the installer, but none of the drivers (all .exe files) are deemed valid by the installer.

Can anyone tell me how to get beyond square one on this? I am embarrassed to have fallen at this first basic hurdle!!

(if only it was esxi then I wouldn't have any wretched driver issues, but the box cannot run esxi)

  • 1
    Can you extract anything from the exe files? Or run the executable with a /? to see if there is a specific extract process so you can look at the individual files? – Mitch Apr 29 '15 at 17:40
  • You almost certainly either need to extract that driver or download a different version of the packaging. A valid driver will be in a directory that includes an .inf file. BTW your comment about ESXi not having drivers issue is a bit odd, since the reason ESXi probably doesn't run is a lack of drivers for that hardware... – Zoredache Apr 29 '15 at 17:48
  • I took a look at one of the packages. HP has an extract button when you run the exe and all of the usable bits are in the package. – Mitch Apr 29 '15 at 18:42
  • without an os, how do I run the .exe? – Nick Harvey Apr 30 '15 at 7:29
  • my vmware comment was based on my using an esxi-qualified system, which the microserver is not! – Nick Harvey Apr 30 '15 at 7:30
3

It's almost like there's a guide you can follow for this :)

But the quickest option for you may be to bootstrap your Windows 2012 R2 installation by using the HP Intelligent Provisioning Utility baked into the system BIOS.

Use the opportunity to update the system BIOS and firmware as well.

The Smart Array RAID controller on the Microserver is the culprit here. It requires a proprietary drive that needs to be loaded before the OS. Intelligent Provisioning will do that for you under Windows 2012 R2.

For Linux and other operating systems, we have to get creative.

  • I am using intelligent provisioning (IP) - it downloads a load of updates (so it seems, but gives no specific details) then takes me to the beginning of the win 2102 install within IP but it stuck overnight (twice) at the line copying: /media/VID/$WinPEDriver$/cp022246.exe/qind6x64.inf - so it looks like its installing drivers, but has problems!! – Nick Harvey Apr 30 '15 at 7:29
  • Can you check to see if your firmware and Intelligent Provisioning are both current? – ewwhite May 1 '15 at 10:26
0

I had exactly the same problem. But I solved it!

If you connect via iLO and mount an ISO image it continues. If you're trying to install with USB, use the Windows USB/DVD Download Tool and extract the ISO to a USB drive, connect it to the server, select /sdb4/sources/ (or mounted USB port number and go under /sources/ that's where the "install.wim" file located), click "Continue" and it should work !!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.