3

so i installed a fresh ubuntu server 14.04 with KVM, i'm connecting with my other ubuntu machine using virt-manager. so after i had permissions problem creating a new VM, i uncomment user="root" and group="root" in /etc/libvirt/qemu.conf and it solved the problem.

but when i try open the graphical console of new VM with virt-manager it stuck in "user@ip" openssh password prompt, no matter how many times i type the password.

same issue with virt-viewer.

i might changed some permissions of folders when trying to solve the first problem. any clue?

p.s. i did purge the libvirtd and reinstall everything.

2 Answers 2

8

I had the same problem

in VM settings change display from "Spice server" to "VNC server" and it should fix the problem.

Issue is, that spice server only allows localhost connection by default. If you want to use spice, than you should change spice setting in hosting machine. Otherwise - use VNC.

3
  • 1
    that is the solution! awesome
    – Morti
    Dec 7, 2015 at 18:30
  • 1
    Same problem - just signed up only to comment on the proposed solution - SAVED me a TON of time, and worked immediately -Thanks!!
    – TSuSE
    Jun 9, 2017 at 8:42
  • No spice solution? Thats a workaround, not the solution.... Jul 1, 2020 at 20:43
0

There's a better solution - as Philippe points out, the above is a workaround.

If you want to stick with "Spice server" as your display type, you can - just make sure to set "Address" = "All interfaces" instead of "localhost only".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.